Clutch Question - LS1GTO.com Forums

Vendors


Go Back   LS1GTO.com Forums > GTO Tech > Drivetrain

Reply
 
Thread Tools Rate Thread
Old 04-24-2012, 02:29 PM   #1
springfield45
06 GTO
 
springfield45's Avatar
 
2006 GTO Owner

Join Date: Apr 2011
Location: cleveland/ohio
Posts: 240


Offline
Clutch Question

I need some help!! My car just had some upgrades and I sent it in to get Dyno tuned. After they got everything situated they gradually started bringing the RPM's up. When it hit between 52/5300 RPM's it was like the clutch just let go and the peddle pushed against his foot. Does anyone Know what would cause this? I am assuming that it needs a new clutch. It has the stock clutch with 30,000 miles on it and the Mustang dyno was reading 420rwhp/418rwtq at between 52/5300. The setup should pull to 6500 Rpm's according to lunati so if I need a new clutch what would be recommend for Auto-X and normal driving.
  Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 04-24-2012, 02:37 PM   #2
Falco21
Registered User
 
Falco21's Avatar
 
2005 GTO Owner

Join Date: Sep 2011
Location: United States
Posts: 2,084


Offline
Sounds like a Slave issue. While you're in there, you should mine as well replace it all. Clutch kit including Slave Cylinder and Pilot Bearing.

As for which clutch, I can't say it enough, but you need to search man. The top competitors seem to be Monster, and Street Slayer. There are other options out there, but the Monster seems to get most attention. I actually have a Street Slayer on the way right now. Search around. You will find plenty of opinions on which unit.
__________________


2005 M6 GTO (Straight Black): K&N Hot Air Intake (b/c I go hard like that!), UDP, Kooks Long Tube Headers, Magnaflow Cat Back, Non-Sponsor StreetSlayer Clutch, B&M Shifter, Drag Bags, Hotchkis Sway Bars
  Reply With Quote Quick reply to this message
Old 04-24-2012, 02:41 PM   #3
Non-Sponsor-Engineering
Banned
 

Join Date: Mar 2005
Posts: 7,792


Offline
  Reply With Quote Quick reply to this message
Old 04-24-2012, 02:44 PM   #4
Falco21
Registered User
 
Falco21's Avatar
 
2005 GTO Owner

Join Date: Sep 2011
Location: United States
Posts: 2,084


Offline
^^^ Great customer service!! Hopefully this clutch treats me well, which I know it will
  Reply With Quote Quick reply to this message
Old 04-24-2012, 02:45 PM   #5
springfield45
06 GTO
 
springfield45's Avatar
 
2006 GTO Owner

Join Date: Apr 2011
Location: cleveland/ohio
Posts: 240


Offline
Did you get the single or twin disk Street Slayer? That was my first pick but I was trying to get some other opinions before I pull the trigger.I have a few Non-Sponsor parts on my car and am very impressed with his quality,fit and finish .
  Reply With Quote Quick reply to this message
Old 04-24-2012, 02:48 PM   #6
Falco21
Registered User
 
Falco21's Avatar
 
2005 GTO Owner

Join Date: Sep 2011
Location: United States
Posts: 2,084


Offline
Single. I am no where near enough power to need the twin disc. The single seems to hold some serious power though. The single will be plenty for your 420.
  Reply With Quote Quick reply to this message
Old 04-24-2012, 02:52 PM   #7
springfield45
06 GTO
 
springfield45's Avatar
 
2006 GTO Owner

Join Date: Apr 2011
Location: cleveland/ohio
Posts: 240


Offline
The car should be building power for another 1300 RPM's.
  Reply With Quote Quick reply to this message
Old 04-24-2012, 02:59 PM   #8
Falco21
Registered User
 
Falco21's Avatar
 
2005 GTO Owner

Join Date: Sep 2011
Location: United States
Posts: 2,084


Offline
Thomas will chime in, but if you want to go with Non-Sponsor, the StreetSlayer should easily handle that power. The single disc
  Reply With Quote Quick reply to this message
Old 04-24-2012, 03:01 PM   #9
OnyxY2KSS
Registered User
 
OnyxY2KSS's Avatar
 
2006 GTO Owner

Join Date: Aug 2007
Location: Houston
Posts: 981


Offline
What'd I miss? How is this a slave issue? Was the clutch not disengaging when pressed in?

Monster owner here btw.
__________________
2000 Camaro¸.·´¯`·.´¯`·.¸¸.·´¯`·.¸.·´¯`·.´¯`·.¸¸.·´¯`·. ¸.·´¯`·.´¯`·.¸¸.·´¯`·.¸¸.·´2006 GTO
http://www.ls1gto.com/forums/signaturepics/sigpic21376_1.gif
  Reply With Quote Quick reply to this message
Old 04-24-2012, 03:02 PM   #10
Falco21
Registered User
 
Falco21's Avatar
 
2005 GTO Owner

Join Date: Sep 2011
Location: United States
Posts: 2,084


Offline
Quote:
Originally Posted by OnyxY2KSS...View Post
What'd I miss? How is this a slave issue?

Could be a number of issues. I said it sounded like a bad slave to me. Either way, the stock clutch he has seems to be going, so mine as well replace it all.
  Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the LS1GTO.com Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Rate This Thread
Rate This Thread:

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 01:15 AM.




Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©2003-2008, LS1GTO.com
Site Banner Design ©2005-2007, Cylosoft

LS1GTO.com is not affiliated with General Motors Corp.