Mp 112 catch can - LS1GTO.com Forums

Vendors


Go Back   LS1GTO.com Forums > GTO Tech > Forced Induction

Reply
 
Thread Tools Rate Thread
Old 04-19-2017, 01:18 PM   #1
Jailor
Registered User
 

Join Date: Jul 2007
Posts: 213


Offline
Mp 112 catch can

Got an 04 with a 112. What catch can are you using and where do you mount it?
The traditional mounting spot is a bit crowded with the intercooler lines.
__________________
04 yj m6 mp 112, 2.7 pulley, meth, vhp custom cam 232-240 585-585,1.8 yella terras, 480/491 dyno jet monster stage 2
  Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 04-19-2017, 03:40 PM   #2
Nothubertjfarnsworth
ಠ_ಠ
 
Nothubertjfarnsworth's Avatar
 
2005 GTO Owner

Join Date: Sep 2006
Location: NWI
Posts: 28,187
Premium Member


Offline
get a vacuum pump.
__________________
( 'o')b

( '_')o

(._. )

Quote:
The real enemy of truth is not ignorance, doubt, or even disbelief. It is false knowledge.

  Reply With Quote Quick reply to this message
Old 04-19-2017, 03:47 PM   #3
Jailor
Registered User
 

Join Date: Jul 2007
Posts: 213


Offline
Quote:
Originally Posted by Nothubertjfarnsworth...View Post
get a vacuum pump.

Could you point me in the right direction as a vendor or such.
And your opinion on this being the source of my oil smoke at cold start?
  Reply With Quote Quick reply to this message
 
Old 04-19-2017, 03:57 PM   #4
joshcarl
Underway
 
joshcarl's Avatar
 
2005 GTO Owner

Join Date: Jun 2011
Location: Ft Belvoir, Va
Posts: 676


Offline
Elite Engineering
__________________
  Reply With Quote Quick reply to this message
Old 04-19-2017, 05:08 PM   #5
Jailor
Registered User
 

Join Date: Jul 2007
Posts: 213


Offline
Quote:
Originally Posted by joshcarl...View Post
Elite Engineering

Is that the "standard" model you have their?
  Reply With Quote Quick reply to this message
Old 04-19-2017, 06:30 PM   #6
Nothubertjfarnsworth
ಠ_ಠ
 
Nothubertjfarnsworth's Avatar
 
2005 GTO Owner

Join Date: Sep 2006
Location: NWI
Posts: 28,187
Premium Member


Offline
Quote:
Originally Posted by Jailor...View Post
Could you point me in the right direction as a vendor or such.

gz motorsports or moroso.


Quote:
Originally Posted by Jailor...View Post
And your opinion on this being the source of my oil smoke at cold start?

nope. i don't have an opinion because i'm not sitting in front of your car to diagnose it. you were given a few options to look at in the other thread you created.
  Reply With Quote Quick reply to this message
Old 04-20-2017, 06:25 AM   #7
Lakegoat
Registered User
 
Lakegoat's Avatar
 
2005 GTO Owner

Join Date: Apr 2007
Location: TX
Posts: 1,842


Offline
I am using a Rev Extreme can for blower motors--has two check valves. I mounted it to the drivers side inner fender with a bolt up thru the fender and bent the supplied bracket. The 04 may have something in the way---I don't know. I also use the GM Performance PCV that they use on the new LSA motors. It plugs into the oil fill and drains it back to the motor. I went so far as buying two passenger side valve covers from a 2000 truck motor as they have baffles built in to the valve covers to make up for no PCV.
Attached Thumbnails
Click image for larger version

Name:	DSC01400.jpg
Views:	29
Size:	532.3 KB
ID:	455897   Click image for larger version

Name:	DSC01399.jpg
Views:	30
Size:	430.6 KB
ID:	455905  
__________________
TVS 2300, 4L80

Last edited by Lakegoat; 04-20-2017 at 06:32 AM.
  Reply With Quote Quick reply to this message
Old 04-20-2017, 09:29 PM   #8
Mike05TurboGto
Registered User
 
Mike05TurboGto's Avatar
 

Join Date: Mar 2017
Location: New York
Posts: 6


Offline
MMS ftw
__________________


Current Setup:
Sbe LS2, 317s, LJMS Turbo cam, meth, s480 96/1.25

17psi: 856HP/876TQ

Best 1/4 Mile time:

10.59@139
That was on 735/739 from last turbo
  Reply With Quote Quick reply to this message
Old 04-22-2017, 05:14 AM   #9
joshcarl
Underway
 
joshcarl's Avatar
 
2005 GTO Owner

Join Date: Jun 2011
Location: Ft Belvoir, Va
Posts: 676


Offline
Quote:
Originally Posted by Jailor...View Post
Is that the "standard" model you have their?

yes
  Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the LS1GTO.com Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Location
Where you live (must be accurate to IP location, if wrong you may be permanently banned)
Insurance
Please select your insurance company (Optional)

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Rate This Thread
Rate This Thread:

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 03:33 AM.




Powered by vBulletin® Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.