e-brake light on when seatbelt fastened - LS1GTO.com Forums

Vendors


Go Back   LS1GTO.com Forums > GTO Tech > Suspension/Steering/Brakes

Reply
 
Thread Tools Rate Thread
Old 01-10-2017, 10:28 AM   #1
jade
Registered User
 

Join Date: Jan 2017
Location: pollock pines, ca
Posts: 2


Offline
e-brake light on when seatbelt fastened

Hi, first time posting on this forum. Have an unusual issue cropped up yesterday on my 2005 GTO (30k mi.) E-brake warning light comes on and stays on as soon as drivers seatbelt is fastened. Light goes off as soon as seatbelt in unfastened. Brake fluid level looks normal, jiggling e brake handle doesn't turn it off. Should there be a link between the seatbelt sensor and the ebrake switch? Any ideas appreciated. Thanks!
  Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 01-11-2017, 06:41 AM   #2
mlformula95
Registered User
 
mlformula95's Avatar
 
2006 GTO Owner

Join Date: Mar 2012
Location: Kentucky
Posts: 148


Offline
Does the ebrake light work when the handle goes up?

The black blue wire from the seat belt buckle runs to a ground above the transmission according to the 05 wiring diagram. The black white wire changes to orange and runs to the cluster.

I would start with taking the center console out and trace the orange and brown wire from the ebrake handle. Inspect that area and all the wires for damage/corrosion.
  Reply With Quote Quick reply to this message
Old 01-11-2017, 08:56 AM   #3
jade
Registered User
 

Join Date: Jan 2017
Location: pollock pines, ca
Posts: 2


Offline
Thanks for the reply. I may have solved the problem. The day before the problem started, the battery had gone dead when I accidentally left the lights on for several hours, and I had to jump start it. It was dead enough that some of the preferences on the dash readouts reset. I unhooked the battery last night for 20 minutes and then hooked it back up and drove home and had no more issue with ebrake light coming on. I've got my fingers crossed that the computer hopefully just needed a reset. If the light comes back on, I'll check the wiring.
  Reply With Quote Quick reply to this message
 
Old 01-11-2017, 11:40 AM   #4
Jontall
1 of 262
 
Jontall's Avatar
 
2006 GTO Owner

Join Date: Apr 2005
Location: NYC
Posts: 10,002


Offline
These cars go crazy when the battery is low or dead... Buy a new battery when you can afford to.
  Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the LS1GTO.com Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Location
Where you live (must be accurate to IP location, if wrong you may be permanently banned)
Insurance
Please select your insurance company (Optional)

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Rate This Thread
Rate This Thread:

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 01:41 PM.




Powered by vBulletin® Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.