tower brace removal - LS1GTO.com Forums

Vendors


Go Back   LS1GTO.com Forums > GTO Tech > Appearance/Detailing

Reply
 
Thread Tools Rate Thread
Old 11-09-2012, 03:57 AM   #1
taylorjwbrown
Premium Member
 
taylorjwbrown's Avatar
 
2006 GTO Owner

Join Date: May 2011
Location: florence, az
Posts: 326
Premium Member


Offline
tower brace removal

Went to remove my tower brace the other day and it was hard as hell to get off /put on. I'm guessing I have to jack the front end up to take the weight off or no? I'm I missing something. I searched but found nothing just "took off old and put bmr on"

I'm not taking it off permanently, just to paint.
  Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 11-09-2012, 04:36 AM   #2
Atroiano
Daily Driver
 
Atroiano's Avatar
 
2005 GTO Owner

Join Date: Oct 2011
Location: Avondale, AZ
Posts: 154


Offline
dude it should just pull off, I've never had an issue with mine and I have the BMR as well
__________________
'05 YJ M6 Rolling on 18" Stockers - Mods??? nothing cool
  Reply With Quote Quick reply to this message
Old 11-09-2012, 04:52 AM   #3
taylorjwbrown
Premium Member
 
taylorjwbrown's Avatar
 
2006 GTO Owner

Join Date: May 2011
Location: florence, az
Posts: 326
Premium Member


Offline
Dude I had to pry it off like the studs were to the inside as much as could be and it was catching.
  Reply With Quote Quick reply to this message
Old 11-09-2012, 05:02 AM   #4
BAAD LS2
450+rwhp club :D
 
BAAD LS2's Avatar
 
2005 GTO Owner

Join Date: Aug 2007
Location: Chicago
Posts: 2,507


Offline
car was probably wrecked at one point or you weren't parked on a flat surface and the body was twisted slightly. Never had a problem getting mine off.
__________________

2005 MBM SAP M6
CCW - BMR - Hotchkis - Whiteline - Lovells - Energy - BCR - D/S Rotors
Kooks - StolenFox - Vararam - Torquer V2 - Billet - Monster - Tick - GForce
Aeroforce - SCSS - 6k low/fog HID's - Tinted '06 Tails - Kircher - DMH - SJM - JamesBiz
Ported FAST92 & TB, SDTuned by GeeTeeOh!... 454rwhp & 432tq Dynograph Link
PB 12.02 @ 116.55 w/ 1.78-60'
  Reply With Quote Quick reply to this message
Old 11-09-2012, 05:06 AM   #5
Vigilante375
Out and about
 
Vigilante375's Avatar
 
2006 GTO Owner

Join Date: May 2006
Location: WA
Posts: 1,398


Offline
I pulled my stock brace off once before and I just had to give it a little tap to get it off. It went back on with no issue's neither.
__________________

'06 Brazen Goat PB 12.62@111.63 - RIP 02/15/11
'12 Alpine White BMW 135i - stock - 13.5@102.6
'11 Lime Green ZX10r - stock

  Reply With Quote Quick reply to this message
Old 11-09-2012, 05:07 AM   #6
Atroiano
Daily Driver
 
Atroiano's Avatar
 
2005 GTO Owner

Join Date: Oct 2011
Location: Avondale, AZ
Posts: 154


Offline
Quote:
Originally Posted by BAAD LS2...View Post
car was probably wrecked at one point or you weren't parked on a flat surface and the body was twisted slightly. Never had a problem getting mine off.

yes... yes it was wrecked LOL, don't ever let him behind you.
  Reply With Quote Quick reply to this message
Old 11-09-2012, 05:36 AM   #7
taylorjwbrown
Premium Member
 
taylorjwbrown's Avatar
 
2006 GTO Owner

Join Date: May 2011
Location: florence, az
Posts: 326
Premium Member


Offline
Quote:
Originally Posted by BAAD LS2...View Post
car was probably wrecked at one point or you weren't parked on a flat surface and the body was twisted slightly. Never had a problem getting mine off.

Rear ended another gto in Sept so that's probably what it is. That thought crossed my mind but didn't think too much into it.

Quote:
Originally Posted by Atroiano...View Post
yes... yes it was wrecked LOL, don't ever let him behind you.

-__- hate you!! Haha
  Reply With Quote Quick reply to this message
Old 11-09-2012, 05:56 AM   #8
BAAD LS2
450+rwhp club :D
 
BAAD LS2's Avatar
 
2005 GTO Owner

Join Date: Aug 2007
Location: Chicago
Posts: 2,507


Offline
Quote:
Originally Posted by taylorjwbrown...View Post
Rear ended another gto in Sept so that's probably what it is.

Stellar work.
  Reply With Quote Quick reply to this message
Old 11-09-2012, 06:08 AM   #9
slammin86
...brah
 
slammin86's Avatar
 
2004 GTO Owner

Join Date: Oct 2004
Location: Rogersville MO
Posts: 8,181


Offline
Frame probably twisted when you removed it.
__________________
04 M6 GTO
Mods: HP Tuners
SD tuned by me
10.9 @ 132 w/ 1.8 60 HAHALOL

99 Civic SI
  Reply With Quote Quick reply to this message
Old 11-09-2012, 07:24 AM   #10
taylorjwbrown
Premium Member
 
taylorjwbrown's Avatar
 
2006 GTO Owner

Join Date: May 2011
Location: florence, az
Posts: 326
Premium Member


Offline
I could barely get it off so I don't think me removing it messed anything up.
  Reply With Quote Quick reply to this message
Old 11-09-2012, 07:45 AM   #11
Unclassified
mrrg
 
Unclassified's Avatar
 
2005 GTO Owner

Join Date: Aug 2011
Location: Outside Andrea's
Posts: 609,335
Premium Member


Online
try jacking up the front when you put it back on.. maybe it will help with the wreck damage. let the frame relax a bit
__________________
(\__/)
(='.'=) This is Bunny. Copy and paste bunny
(")_(") into your signature to help him gain world domination.

Quote:
Originally Posted by Andrea...View Post
I love me some bananas.

Quote:
Originally Posted by Andrea...View Post
Ditto...I too suck ...


212-479-7990
  Reply With Quote Quick reply to this message
Old 11-09-2012, 08:38 AM   #12
rockingoat
nitrous? yes please...
 
rockingoat's Avatar
 
2006 GTO Owner

Join Date: Aug 2012
Location: byron illinois
Posts: 192
Premium Member


Offline
My stock ones is easy to get on and off switched to a Non-Sponsor one and its a sob to get on and off buts a totally differnt mounting set up.
__________________
it was fun but the gto is for sale check it out in the for sale section
  Reply With Quote Quick reply to this message
Old 11-09-2012, 09:07 AM   #13
taylorjwbrown
Premium Member
 
taylorjwbrown's Avatar
 
2006 GTO Owner

Join Date: May 2011
Location: florence, az
Posts: 326
Premium Member


Offline
Anyone still have the stock one on that can look and see where their studs are sitting insidethe mounting holes (ie: centered in the holes, all the way to the inside or outside) mine are to the inside all the way.
  Reply With Quote Quick reply to this message
Old 11-10-2012, 06:23 AM   #14
Raxus GTO
Buckeye Goat
 
Raxus GTO's Avatar
 
2004 GTO Owner

Join Date: Oct 2011
Location: Barberton, OH
Posts: 463


Offline
My stock and BMR both come on/off very easily. I remember my buddies car was not the same. His was lightly wrecked at one point, but you could not tell that it ever was visually. We got off the stocker, but it took a good 30 minutes to get on the BMR via jacking the car up differently. What a PIA... lol
__________________
2004 TR LS1 A4
Kooks 1 3/4 LT
Spintech SPS Catback
SVEDE ORTCAI
VMR VB3 CSL's
Lovells / Whiteline Suspension
BMR STB & Skid Plate, Kircher Splitter, WCS SAP Grilles
Mav Man Lip Spoiler, Shadow Speed Roof Spoiler
06 Exterior Conversion, Carmotorsports Mats
Mav Man & Jamesbiz billet pieces
JHP Gauges & Door Lock Kit, Aeroforce Gauges, Bohnman Full LED + Aux Conversion
CTS-V Front & Rear Brembo's, Russell SS Brake Lines & Fuel Line, 35%Tint
Tuned by BSP 327.97HP / 339.86TQ


  Reply With Quote Quick reply to this message
Old 11-10-2012, 07:09 AM   #15
01SS346
Registered User
 
01SS346's Avatar
 
2004 GTO Owner

Join Date: Dec 2004
Location: Overland Park KS
Posts: 794


Offline
Its because your cars been wrecked.

Sent from my GT-P5113 using AutoGuide.Com Free App
__________________
04 PBM M6 GTO - Pedders XA's/All Bushings/Ported 5.3L Heads/Ed Curtis Custom Cam/Kooks 1 7/8ths headers No cats/Magnaflow Exhaust/Volant CAI/4.10 Gears with Harrop Cover and Harrop LSD/G Force DS with Billet Yoke/42Lbs Injectors/Chrome 18's (OEM)/06 Brake Conversion/Limo Tint/Eclipse Nav system/HID Low and Fogs/SAP Front and Rear bumper/SAP Grills/Spoiler Delete
  Reply With Quote Quick reply to this message
Old 11-10-2012, 07:51 AM   #16
Unclassified
mrrg
 
Unclassified's Avatar
 
2005 GTO Owner

Join Date: Aug 2011
Location: Outside Andrea's
Posts: 609,335
Premium Member


Online
Quote:
Originally Posted by BAAD LS2...View Post
car was probably wrecked at one point or you weren't parked on a flat surface and the body was twisted slightly. Never had a problem getting mine off.







Quote:
Originally Posted by Atroiano...View Post
yes... yes it was wrecked LOL, don't ever let him behind you.







Quote:
Originally Posted by taylorjwbrown...View Post
Rear ended another gto in Sept so that's probably what it is. That thought crossed my mind but didn't think too much into it.



-__- hate you!! Haha







Quote:
Originally Posted by Tishkevich...View Post
try jacking up the front when you put it back on.. maybe it will help with the wreck damage. let the frame relax a bit







Quote:
Originally Posted by 01SS346...View Post
Its because your cars been wrecked.

Sent from my GT-P5113 using AutoGuide.Com Free App

Awesome, did you think of that?
  Reply With Quote Quick reply to this message
Old 11-10-2012, 07:54 AM   #17
taylorjwbrown
Premium Member
 
taylorjwbrown's Avatar
 
2006 GTO Owner

Join Date: May 2011
Location: florence, az
Posts: 326
Premium Member


Offline
Quote:
Originally Posted by Tishkevich...View Post
Awesome, did you think of that?

Haha I gotta chuckle outta this. Just did what you said and jacked the car up it came right off.

Painting it now
  Reply With Quote Quick reply to this message
Old 11-10-2012, 08:32 AM   #18
01SS346
Registered User
 
01SS346's Avatar
 
2004 GTO Owner

Join Date: Dec 2004
Location: Overland Park KS
Posts: 794


Offline
I'd be more worried as to WHY you have to do that.

Sent from my GT-P5113 using AutoGuide.Com Free App
  Reply With Quote Quick reply to this message
Old 11-10-2012, 08:48 AM   #19
taylorjwbrown
Premium Member
 
taylorjwbrown's Avatar
 
2006 GTO Owner

Join Date: May 2011
Location: florence, az
Posts: 326
Premium Member


Offline
Because I rear ended another gto at 10 MPH, hit him with the driver front. I slammed on the brakes, rear end locked up went sideways and smashed the front.
  Reply With Quote Quick reply to this message
Old 11-10-2012, 08:50 AM   #20
TheRocket
I Wanna Go Fast
 
TheRocket's Avatar
 
2005 GTO Owner

Join Date: Sep 2010
Location: El Paso, TX
Posts: 2,339


Offline
I didn't quite catch that you had been in an accident from this thread . . .
__________________

2005 Pearl Orange Metallic
PB:12.98@107.1mph
LS3 Intake/Heads - Comp Custom Grind Cam 224/230 .609/.609 113+2 - FTI 3200 Triple Disc - Svede - Lunati - Katech - Cometic - GMPP - SLP - Kooks - MagnaFlow - BC 8/10k Coilovers - Pedders - Whiteline - DBA - Hawk - TSW Cadwells - Goldilocks Splitter - Maverick Man Carbon Spoiler - Morimoto - 06 Tails - Elemental Designs Nine.1 Amp - Phoenix Gold - Hybrid Audio - TC Sounds - Kenwood
  Reply With Quote Quick reply to this message
Old 11-10-2012, 08:51 AM   #21
taylorjwbrown
Premium Member
 
taylorjwbrown's Avatar
 
2006 GTO Owner

Join Date: May 2011
Location: florence, az
Posts: 326
Premium Member


Offline




this was 6 weeks ago.
  Reply With Quote Quick reply to this message
Old 11-10-2012, 08:52 AM   #22
taylorjwbrown
Premium Member
 
taylorjwbrown's Avatar
 
2006 GTO Owner

Join Date: May 2011
Location: florence, az
Posts: 326
Premium Member


Offline
this is now

  Reply With Quote Quick reply to this message
Old 11-10-2012, 08:57 AM   #23
taylorjwbrown
Premium Member
 
taylorjwbrown's Avatar
 
2006 GTO Owner

Join Date: May 2011
Location: florence, az
Posts: 326
Premium Member


Offline
Quote:
Originally Posted by Gobaltss...View Post
Accident probly has something to do with it

tis what i've concluded, but it came right off when i jacked the car up so i'm not worried bout it
  Reply With Quote Quick reply to this message
Old 11-10-2012, 09:03 AM   #24
TheRocket
I Wanna Go Fast
 
TheRocket's Avatar
 
2005 GTO Owner

Join Date: Sep 2010
Location: El Paso, TX
Posts: 2,339


Offline
Actually OP, now that I'm not being a smart ass . . . if it makes you feel any better, I had the same problem a few weeks ago when I tried to put mine back on after I got my car back from the shop. Couldn't get it on until I jacked the car up from the middle of the cradle.

I've never been in an accident.
  Reply With Quote Quick reply to this message
Old 11-10-2012, 09:05 AM   #25
taylorjwbrown
Premium Member
 
taylorjwbrown's Avatar
 
2006 GTO Owner

Join Date: May 2011
Location: florence, az
Posts: 326
Premium Member


Offline
Quote:
Originally Posted by TheRocket...View Post
Actually OP, now that I'm not being a smart ass . . . if it makes you feel any better, I had the same problem a few weeks ago when I tried to put mine back on after I got my car back from the shop. Couldn't get it on until I jacked the car up from the middle of the cradle.

I've never been in an accident.

lol i was picking up the sarcasm

i'm not worried about it, it drives straight doesn't puppy track or anything and the alignment is perfect. once i jacked it up i undid the nuts and it just pulled right off.

i wonder what the shop did to yours, thats weird?
  Reply With Quote Quick reply to this message
Old 11-10-2012, 09:36 AM   #26
TheRocket
I Wanna Go Fast
 
TheRocket's Avatar
 
2005 GTO Owner

Join Date: Sep 2010
Location: El Paso, TX
Posts: 2,339


Offline
Quote:
Originally Posted by taylorjwbrown...View Post
lol i was picking up the sarcasm

i'm not worried about it, it drives straight doesn't puppy track or anything and the alignment is perfect. once i jacked it up i undid the nuts and it just pulled right off.

i wonder what the shop did to yours, thats weird?

Not a damn thing for two weeks. I work at a dealership and got to see every part of my transmission rebuild. She became a lift queen during that time . Since I work there and had it done for cheap on the side, I had to be put on the back burner. People with money > People like me, without money.

Actually, the strut bar was off after a recent cam/head/intake/stall/oil pump/slash more bullshit/slash . . . and it never got put back on for the longest time.

So when I got it back a couple weeks ago from a tranny rebuild, I put it on and was having all kinds of issues. I'm thinking my drive-way wasn't level enough. Who knows. 'Works' now. She's going back into the shop haha.
  Reply With Quote Quick reply to this message
Old 11-10-2012, 10:18 AM   #27
taylorjwbrown
Premium Member
 
taylorjwbrown's Avatar
 
2006 GTO Owner

Join Date: May 2011
Location: florence, az
Posts: 326
Premium Member


Offline
Quote:
Originally Posted by TheRocket...View Post
Not a damn thing for two weeks. I work at a dealership and got to see every part of my transmission rebuild. She became a lift queen during that time . Since I work there and had it done for cheap on the side, I had to be put on the back burner. People with money > People like me, without money.

Actually, the strut bar was off after a recent cam/head/intake/stall/oil pump/slash more bullshit/slash . . . and it never got put back on for the longest time.

So when I got it back a couple weeks ago from a tranny rebuild, I put it on and was having all kinds of issues. I'm thinking my drive-way wasn't level enough. Who knows. 'Works' now. She's going back into the shop haha.

lol jesus man, two weeks!! well mine took 5 weeks for the front to get fixed and finished it was like a brand new car when i got it back lol

what is she going back into the shop for? sounds like a typical gto to me lol
  Reply With Quote Quick reply to this message
Old 11-10-2012, 10:47 AM   #28
TheRocket
I Wanna Go Fast
 
TheRocket's Avatar
 
2005 GTO Owner

Join Date: Sep 2010
Location: El Paso, TX
Posts: 2,339


Offline
Quote:
Originally Posted by taylorjwbrown...View Post
lol jesus man, two weeks!! well mine took 5 weeks for the front to get fixed and finished it was like a brand new car when i got it back lol

what is she going back into the shop for? sounds like a typical gto to me lol

The torque converter and valve body is getting pulled again to be sent to FTI for inspection and replacement since I'm having lock up issues. So she should be down for another. . . couple of weeks lol.
  Reply With Quote Quick reply to this message
Old 11-11-2012, 06:29 AM   #29
Unclassified
mrrg
 
Unclassified's Avatar
 
2005 GTO Owner

Join Date: Aug 2011
Location: Outside Andrea's
Posts: 609,335
Premium Member


Online
Quote:
Originally Posted by 01SS346...View Post
Its because your cars been wrecked.

Sent from my GT-P5113 using AutoGuide.Com Free App

Quote:
Originally Posted by BAAD LS2...View Post
car was probably wrecked at one point or you weren't parked on a flat surface and the body was twisted slightly. Never had a problem getting mine off.


Quote:
Originally Posted by taylorjwbrown...View Post
Rear ended another gto in Sept so that's probably what it is. That thought crossed my mind but didn't think too much into it.



-__- hate you!! Haha

Quote:
Originally Posted by Gobaltss...View Post
Accident probly has something to do with it

oh man another original thinker here..

i actually think it's because he had his friend standing next to the car which threw off the balance of the pavement and there for causing the car to be off balance!

OP just make sure you balance the car on auto balancing pavement like they have at mechanics shops!
  Reply With Quote Quick reply to this message
Old 11-11-2012, 02:12 PM   #30
taylorjwbrown
Premium Member
 
taylorjwbrown's Avatar
 
2006 GTO Owner

Join Date: May 2011
Location: florence, az
Posts: 326
Premium Member


Offline
Quote:
Originally Posted by TheRocket...View Post
The torque converter and valve body is getting pulled again to be sent to FTI for inspection and replacement since I'm having lock up issues. So she should be down for another. . . couple of weeks lol.


Lol Jesus man! Seems like we can't win with these cars :-) but they are still fun


Quote:
Originally Posted by Tishkevich...View Post
oh man another original thinker here..

i actually think it's because he had his friend standing next to the car which threw off the balance of the pavement and there for causing the car to be off balance!

OP just make sure you balance the car on auto balancing pavement like they have at mechanics shops!


My thoughts exactly, the inline specs of the rotary girder were threw off by the geometry of said buddy .3464 inches too far to the right...

I painted it and she's a beaut!!! The smurfin clear coat cap messed up and would puddle under the cap and spray drops of clear on it, looked so good til the last coat...still looks good and hardly noticeable but I woulda loved 4 coats of clear instead of two...oh well time to paint the svede when it comes in :-)
  Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the LS1GTO.com Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Rate This Thread
Rate This Thread:

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 08:01 AM.




Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 2003-2008, LS1GTO.com
Site Banner Design 2005-2007, Cylosoft

LS1GTO.com is not affiliated with General Motors Corp.