Airbag fault - LS1GTO.com Forums

Vendors


Go Back   LS1GTO.com Forums > GTO Tech > Electronics

Reply
 
Thread Tools Rate Thread
Old 01-16-2013, 02:30 PM   #1
Blazer15
Registered User
 
Blazer15's Avatar
 
2006 GTO Owner

Join Date: May 2011
Location: palm beach gardens
Posts: 608


Offline
Airbag fault

Hey guys.

My airbag fault light has been on for a little while now. I've taken it to a buddy who has a shop (no tech II), he was able to clear it but it came back the next day.

I never took the seats out so I'm lost as to what it could be.

When I did my search, I came up with bad clock springs and people who left there battery connected and removed a seat.

I was thinking of taking it to the dealer but don't want to get raped in the process.

Any thoughts of what it might be? Once I can fix it, then I'll take it to get cleared.

Thanks guys.



Sent from my iPhone using AutoGuide.com App
__________________
___SLOW GOAT___
  Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 01-16-2013, 02:34 PM   #2
Fox Mulder
Alien Moderator
 
Fox Mulder's Avatar
 
2005 GTO Owner

Join Date: Feb 2006
Location: NYC
Posts: 8,682
Premium Member


Offline
Sorry but we're pissing in the wind unless you can get it scanned and retrieve a code. It's the same as a check engine light- no code, SOL. Although, if it is a bad clock spring you can get a hint if the horn doesn't work.
One thing I can suggest is check your battery, sometimes a weak battery will cause a spurious airbag light when nothing is wrong.
__________________
05 GTO/ '15 WRX/ '02 WRX
  Reply With Quote Quick reply to this message
Old 01-16-2013, 02:40 PM   #3
Blazer15
Registered User
 
Blazer15's Avatar
 
2006 GTO Owner

Join Date: May 2011
Location: palm beach gardens
Posts: 608


Offline
Oh, I didn't realize the airbag light had specific codes within it like the check engine light.

Alright, we'll I guess I'll go to the dealership and see if they can scan it for me.

Thanks, Fox.


Sent from my iPhone using AutoGuide.com App
  Reply With Quote Quick reply to this message
Old 01-25-2014, 10:59 AM   #4
eviljared
Registered User
 
eviljared's Avatar
 
2005 GTO Owner

Join Date: Jul 2010
Location: Schofield Barracks, HI
Posts: 27


Offline
How about this: Airbag light comes on, no code. Assume it's SDM lack of communication and replace. With new SDM, airbag light comes on, no code. Have u heard of any similar situations?

Sent from AutoGuide.com App
__________________
'05 TR/Red and Black M6 17s

K&N CAI, SLP LTs, Catless Mids, SLP Loudmouth

367 RWHP 367 RWTQ
  Reply With Quote Quick reply to this message
Old 01-25-2014, 12:34 PM   #5
Shawshank
Cyclone Gray Moneypit
 
Shawshank's Avatar
 
2005 GTO Owner

Join Date: Oct 2012
Location: Texas
Posts: 1,994


Offline
Quote:
Originally Posted by eviljared...View Post
How about this: Airbag light comes on, no code. Assume it's SDM lack of communication and replace. With new SDM, airbag light comes on, no code. Have u heard of any similar situations?

Sent from AutoGuide.com App

Having the airbag light on doesn't necessitate having a code. Check out the VZ Airbag thread here on the forums
  Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the LS1GTO.com Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Rate This Thread
Rate This Thread:

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 08:13 PM.




Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 2003-2008, LS1GTO.com
Site Banner Design 2005-2007, Cylosoft

LS1GTO.com is not affiliated with General Motors Corp.