LS1GTO.com Forums banner

41 - 60 of 64 Posts

·
Registered
Joined
·
187 Posts
Discussion Starter #41
The low mileage engine I've been trying to find yes.

I'd consider a iron block as welll. Just havent found what I want yet
 

·
Registered
Joined
·
187 Posts
Discussion Starter #45
08 l76 from a g8
24x
Baby cam (223-228 I think)
Rebuilt bored .020
All new everything ls2 stock replacements
Hand port and polish heads

Once I get it fine tuned and all the bugs worked out it will get a big cam with supporting hardware and well go for 500+ whp
 

·
Registered
Joined
·
187 Posts
Discussion Starter #47
It already has a cam installed to get rid of the vvt and I know it runs so I rather not jack with it now.
 

·
Registered
Joined
·
187 Posts
Discussion Starter #52
Valley cover installed
Stock ls1 intake installed for initial startup/break in
Trying a new header paint/method to see if it lasts
Some rear driveshaft backing out hopefully fix.

Now just doing what takes all the time. Misc sensors, coolant, tuning, ect ect ect :/
 

Attachments

·
Registered
Joined
·
187 Posts
Discussion Starter #54
Welp had to pull the trans out
Thought I forgot the back dumbbell but I didnt.
Now I have a oil leak. Back to tearing off the rear cover. (I'm getting good at it though)

But it does run! My video wont load though :(
 

·
Registered
Joined
·
187 Posts
Discussion Starter #56
When I put the back cover on I started it within 20 mins. No way the rtv set up. I think that's whathappened. I ordered a new gasket and rear main seal just in case
 

·
Registered
Joined
·
689 Posts
Rear main issue? Mine blew out from too much pressure. Fixed that and put a new seal in. Didn’t align the cover well enough so it still leaked. Still leaks a bit, gonna drop it again as the clutch is messed up and use an actual alignment tool for the rear main.
 

·
Registered
Joined
·
187 Posts
Discussion Starter #59
It's the driver side bottom bolt leaks. I think I ripped my pain o ring some.
I bought some copper gasket sealer and some rubber sealer stuff. It's all out war on it lol
 

·
Registered
Joined
·
187 Posts
Discussion Starter #60
To update this thread.
My relief valve stuck open on my melling oil pump. My car was idling and I was not in the car. It was at 7 psi but no knocking.
Long story short I pulled the engine to take a peek. Ended up replacing the main and rod bearings.

Also since it was out I put a 232 234 .600 lift cam in.

Almost ready to go. Corona is slowing down my shipment of last parts
 

Attachments

41 - 60 of 64 Posts
Top