LS1GTO Forums banner

1 - 5 of 5 Posts

·
Owns 3 GTO's
Joined
·
16,515 Posts
Discussion Starter · #1 ·
I am going to install an 05' cluster in my 04'. I will be having Chris do the programming. Wanted to have it done after I put the car away for winter. My question is, can I drive the car with an untuned cluster without any big problems? I want to get some miles on the cluster to be close to the milage of my 04'. I need to bring the car in for a few things right after spring starts. I want to have about the same miles as I did this spring. Some may not understand my ways of thought. I just want to know if the car will be ok for about 3k miles?
 

·
.. .. .. ..
Joined
·
1,025 Posts
I don't know about an 05 working in an 04 without being "fixed" from Chris White. I know same years will work fine, but I think the different years need special programming.
 

·
Owns 3 GTO's
Joined
·
16,515 Posts
Discussion Starter · #3 ·
I have had the 05' cluster in the car. I turned it on. Just like Chris stated before. Some sevice lights cam on. Seamed as if the mph was right on, and the rpm's looked right too. Just want to know what long term, so to speek, would be like without the mods right now. I need to get a dyno tune first.
 

·
I hack cars.
Joined
·
8,111 Posts
Uhh.. RPM will be messed up, brake light will chime at you the entire time you are driving ABS module gets bumped off the bus as I recall as well.. not a real good idea.. Cruise wont work either..
 

·
Owns 3 GTO's
Joined
·
16,515 Posts
Discussion Starter · #5 ·
No ABS problems yet. Do have the brake light, and the chime comming on ever time I stop, or every few minuts of driving. The RPM's get a little further off as I get higher in the rang. Not bad so far. Think I got someone local I trust with an 05' to add milage for me in there car. Just don't want to upset the dealer with lower milage than my last trip to them.

Thanks Chris, you should see this cluster soon, I hope.
 
1 - 5 of 5 Posts
Top