LS1GTO.com Forums banner

1 - 20 of 40 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #1
Ok, before anyone beats me over the head with "do a search", I did. However no answers were in evidence.

The basics: 06 gto 4a. Ran fine this morning. Took it out and cleaned it up (nothing sprayed anywhere near electronics) for a car show this afternoon. This afternoon turn key and accessories all come on, but engine doesn't crank up.

Checked ALL fuses under dash and hood including bcm. Electrical connections at battery, block and starter. Checked battery too. All fine. Key fob battery still good, locks, unlocks, and unlatched. Key fob not mangled or manhandled. Tried in neutral as well, same results. Wires not burned by headers. Wires not damaged behind glovebox. Left key in on position for 10 min. Disconnected battery for 10 min. Cleaned battery connections and leads. Put key in and out of ignition many many times. Still nothing. No codes thrown on obd2. I don't want to wait til monday to have it towed to the local gm dealer
 

·
Registered
Joined
·
139 Posts
Do you hear the fuel pump running when you turn the key from completely off to accessories? Kind of a high pitched whine coming from the trunk. If not, you can unscrew the Schrader valve on the fuel rail and try turning the engine over. If fuel escapes, then your fuel pump should be working fine. If not, your fuel pump/fuel pump assembly tower may have failed.
 

·
Registered
Joined
·
67 Posts
Grounds, 3 stacked on the passenger side wheel house, another on the same side head and of course the battery
 

·
Registered
Joined
·
491 Posts
Do you hear the fuel pump running when you turn the key from completely off to accessories? Kind of a high pitched whine coming from the trunk. If not, you can unscrew the Schrader valve on the fuel rail and try turning the engine over. If fuel escapes, then your fuel pump should be working fine. If not, your fuel pump/fuel pump assembly tower may have failed.
?:wall:
 

·
Registered
Joined
·
139 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #10 (Edited)
Fuel pump works. Can hear it run for a couple of seconds if I vent pressure at the Schrader valve.

Because I needed them anyway I ordered 2 more keys from the local gm dealer this week. They couldnt/wouldn't even estimate when they would arrive. Oh boy. I suspect the security system and the one key I got with my car has seen better days even if the primary one looks good, it has some age on it and I'm suspicious.

I had it running all week until tonight when it stranded me again. I've checked the electrical connections, but this isn't acting like a bad ground. Its acting like the computer is not energizing the starter control circuit.

Still throws no codes via obd2 reader.

No idea what changed to get it running or to fail again. I've had this car a month now and when it runs I love it, tonight though....not so much.
 

·
Worthless reject member
Joined
·
36,217 Posts
You should first verify it's not the immobilizer or theft system. Also try cleaning the key ring on the column around the lock cylinder and making sure the key fob nub makes contact with it.

No blinking theft light or immobilizer codes? Key nub and ring make good contact, and the key fob locks/unlocks the doors? Move on to the starting circuit. I've already mentioned two basic components you should troubleshoot.
 

·
Registered
Joined
·
21 Posts
Discussion Starter #13
Light only blinks with locks set. Cleaned key and ring with alcohol. No visible issues with nub contacting the ring.
 

·
Registered
Joined
·
21 Posts
Discussion Starter #17
How do I verify that it's not the immobilizing circuit? I have fuel pressure and all accessories. I've swapped relays around where possible based on relay part number to no effect. From what I've read it sounds like exactly what the immobilizer does. However I'm open to it being something else.
 

·
Registered
Joined
·
21 Posts
Discussion Starter #19 (Edited)
Got a ride back here, but forgot my meter in my rush to catch the ride. This is decidedly not fun. Really don't appreciate it happening only on weekends either. Sorry, it's hot out here and I'm getting frustrated. Itd be so much easier to work in my garage.
 
1 - 20 of 40 Posts
Top