LS1GTO Forums banner

1 - 11 of 11 Posts

·
not driving if I'm posting
Joined
·
448 Posts
Discussion Starter #1
Has anyone installed the Eclipse AVN2454 yet? If so I'd like to see some pictures and let me know how difficult it was to install.

Thanks,
John
 

·
Blowed Up...
Joined
·
11,360 Posts
I will be installing one in a few weeks! I will let you know then
 

·
not driving if I'm posting
Joined
·
448 Posts
Discussion Starter #3
Well I got the unit installed yesterday and it's pretty nice.

I am having a problem with the GPS though. It didn't know where I was, LA vs. Richmond, VA. I took it back to the installer today and he tried to fix the problem. He manually moved the location to the correct spot (it was only off about 2500 miles :eek2: ) and all looked good until I started driving.

The icon hits the road and heads out correctly, but goes way faster than I am traveling. By the time I hit the first intersection the icon was at the second intersection down the road. Another strange thing is the clock (I assume set by the GPS) is off about 7-8 minutes compared to my PCS phone. The installer has no idea what the problem is and is calling Eclipse to see if they have any info.

The antenna is installed in the front windshield and seems to be getting a signal, but there does not appear to be any GPS status screen.

Any ideas would be appreciated.
 

·
GO STEELERS!
Joined
·
5,106 Posts
Pics?
 

·
Registered
Joined
·
52 Posts
I was going to put that same unit in My GTO, is it hard to get in? and is there any Kits avail. for it. please let me know, I am going to buy it off a friend on Monday.... just wanted to know if it was worth it.
 

·
not driving if I'm posting
Joined
·
448 Posts
Discussion Starter #6 (Edited)
jayydogg said:
I was going to put that same unit in My GTO, is it hard to get in? and is there any Kits avail. for it. please let me know, I am going to buy it off a friend on Monday.... just wanted to know if it was worth it.
No, I don't believe there are any kits available yet. I had it installed so I can't really say how hard it was. They did it in an afternoon. They had to make the face plate. They have a truck they are doing a custom install on in black suede. They used the same material since the GTO has suede trim in it already. Looks good.

I'm happy with the features (assuming the GPS will work soon), but I wouldn't say the sound is great. I think I will have to get an amp(s) added.
 

·
GO STEELERS!
Joined
·
5,106 Posts
If they would have done it in Red Suede and made the lines a little better it would be bad ass.
 

·
not driving if I'm posting
Joined
·
448 Posts
Discussion Starter #8
Found the problem with the GPS signal. Apparently the antenna can't get a strong enough signal through the front windshield. I took the antenna out and taped it to the front windshield for testing (not really the best look) and the unit worked perfectly. Taking it back tomorrow to have the antenna moved.
 

·
Registered
Joined
·
19 Posts
avn

04blkGTO said:
Found the problem with the GPS signal. Apparently the antenna can't get a strong enough signal through the front windshield. I took the antenna out and taped it to the front windshield for testing (not really the best look) and the unit worked perfectly. Taking it back tomorrow to have the antenna moved.

I had this unit installed last week. I had a custom kit made, and then it was sent out to have it painted to exactly match the rest of the dash. It was rather expensive, but you absolutely cannot tell any difference in the plastic, the texture/color, or fit. It totally looks stock.

Wish I could post the pics, but it seems there is a limit on the size of the files, and all of mine are over a 100, so it won't let me upload them.

Also, my antenna was mounteed near the back of the dash, close to the bottom of the winshield; its worked fine, haven't had any problems.

I love this unit, for once I'm not getting lost all the time!

Chris
 

·
Registered
Joined
·
3 Posts
christopherxy1 said:
I had this unit installed last week. I had a custom kit made, and then it was sent out to have it painted to exactly match the rest of the dash. It was rather expensive, but you absolutely cannot tell any difference in the plastic, the texture/color, or fit. It totally looks stock.

Wish I could post the pics, but it seems there is a limit on the size of the files, and all of mine are over a 100, so it won't let me upload them.

Also, my antenna was mounteed near the back of the dash, close to the bottom of the winshield; its worked fine, haven't had any problems.

I love this unit, for once I'm not getting lost all the time!

Chris
You mentioned that you couldn't post pics. Can you email them to me? [email protected]
 
1 - 11 of 11 Posts
Top