LS1GTO Forums banner

1 - 5 of 5 Posts

·
Because race car
Joined
·
2,835 Posts
Discussion Starter #1 (Edited)
Here you go...a little vid that another member took this weekend at the Bristol autox.
Started at the end of the first run. Got a little "bang" and "clunk" noise when cornering hard. In the last 2 turns.

Pretty sure it's my Whiteline endlinks because I had a similar problem the first week I had them. I didn't locktite the 2 nuts at the end of the turnbuckle....they loosened....and I heard a clunk when I went over speed bumps. I tightened them up and the clunk went away.

Sounds like a similar clunk now. Retightened those nuts after the second run and clunk was still there on the third. Retightened everything on the endlink but never got a 4th run....so no testing. Did I mention I got a nail in my tire somewhere along the line....so I have to get that fixed before I go find a nice abandoned parking lot.

But in the mean time: Can anyone ID the clunk. Everything else seemed tight underneath, and it only clunked when I did a quick left/right turn or vica versa (slaloming and what not) which makes me think it is sway bar related.

Thanks!

Link to other thread
 

·
Beer Geek
Joined
·
3,713 Posts
The one around second #15 and then again around second #18 in the clip?
 

·
Because race car
Joined
·
2,835 Posts
Discussion Starter #4
That would be them. The first when I take the hard left (and the car is kinda bouncy) and then just as I turn back and put the weight on the other side.

So wierd....and yes, it did sound loud in the car.

Frank....just out of curiosity, what makes you think strut top bushing?
 

·
GTO no more baaah!
Joined
·
1,150 Posts
also still chasing down the steering pop..
 
1 - 5 of 5 Posts
Top