LS1GTO Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
273 Posts
Discussion Starter · #1 ·
Hello, I have a 05 gto with a procharger. I just recently did a cam swap, I went with the CCP Jam Cam which has 4 degrees of overlap. Now, before I got the cam I would get some backfire while downshifting, probably because I have the deacceleration fuel cutoff still disabled from when I initially did a SD tune. But now, even when I'm not decelerating and coasting after letting off the gas, I occasionally get a random aggressive backfire that is sometimes loud enough to even startle me since I'm not expecting it. For example, just today I accelerated with about 30-40% throttle and then let off the gas, pushed in the clutch and put the car in neutral, then about 2 seconds later I heard 2 back to back explosions one from each exhaust tip. I understand since this cam has some overlap and therefore some unused air is being pushed into the exhaust, this may be normal, I'm just curious if it is normal to be this intense and as random as it is? In most scenarios, if I accelerated like I did earlier, it won't backfire.
My relevant mods are... e85, stainless works long tube headers, no cats, Magnaflow 3inch competion series exhaust, br7ef spark plugs.

Thanks.
 

·
Premium Member
Joined
·
1,578 Posts
it should. youre not pulling the fuel out when you push the clutch in. id think its igniting in the exhaust once there although temps would be pretty high

why dont you re-enable those?
 

·
Registered
Joined
·
273 Posts
Discussion Starter · #5 ·
it should. youre not pulling the fuel out when you push the clutch in. id think its igniting in the exhaust once there although temps would be pretty high

why dont you re-enable those?
I'm at work right now, but on my break I drove my car and watched my a/f Guage. It doesn't appear to be going rich when I push in the clutch.
I'm going to re-enable them but I am still tuning my car for sd. I've had a couple set backs and lots of rain stopping me from tuning wot.
 
1 - 5 of 5 Posts
Top