LS1GTO Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3,373 Posts
Discussion Starter #1
I have a 06 M6 and have installed a oil pressure gauge. Lately the check oil display keeps coming on. I have checked the fliud level and it is in the safe operating range. Oil pressure reads 40 psi.
 

·
I mean it felt like a high 12
Joined
·
1,174 Posts
how many miles?
 

·
Administrator
Joined
·
9,486 Posts
Is it the Check Oil warning or the Service Engine Oil warning? Just need to clarify as there is a big difference.
 

·
THE ROKET WAS SOLD ON 6/22/14
Joined
·
9,794 Posts
sandu002 said:
I have a 06 M6 and have installed a oil pressure gauge. Lately the check oil display keeps coming on. I have checked the fliud level and it is in the safe operating range. Oil pressure reads 40 psi.
There might be something shorting out the signal from the aftermarket gauge. Just a guess because you say everything checks out fine as far as enough oil in the engine.

ROK


.
 

·
Registered
Joined
·
3,373 Posts
Discussion Starter #5
Car has 3000 miles on it. It is the check oil display. Someone suggested I check manual to see how to clear it. My mechanic is going to check the electrical connections.

thanks guys
 

·
Administrator
Joined
·
9,486 Posts
If it's the "Check Oil" display with the oil can icon, the ECU thinks the oil pressure is too low. Did you install a separate sensor for your gauge or is it tapped into the wiring for the existing sensor? If it's tapped that may be your problem if the gauge is loading down the circuit.
There is no procedure in the manual to clear this warning, only a reset for the "Service Oil" indicator which is different.
 
1 - 6 of 6 Posts
Top