LS1GTO Forums banner
1 - 19 of 19 Posts

· Registered
Joined
·
858 Posts
Discussion Starter · #1 ·
I am finishing up my A4 to M6 swap on my 04 GTO. Some of you may know this if you've seen my other thread.

The only thing that is holding me up is that I can not find the connectors that the clutch pedal position sensor connect to. The switch is pictured. It is the switch on the clutch pedal, closest to the floor. There is about 6 inches of wire that come off the switch and split into two connectors. I've taken out the air ducts and all the trim pieces I can to clearly see the main wiring harnesses down there. I've been searching for where these connectors plug into for weeks now with no luck.

Everyone I've talked to said the A4 and M6 interior wiring harnesses are the same and that I just have to find these connectors. If anyone could PLEASE tell me where these are located, I'd really appreciate it. Heck, I'll even send you some $$ through paypal for your time. I just really need to find where these plug into before I :bomb:

I really wanted to keep this swap as clean as possible, but I really need to get this car running. If anyone has a wiring diagram or knows where I can splice the wires for this switch to function properly, please let me know. I have the ECM relocated to the drivers side footwell, so those wires are easy to tap into. The BCM and OBD2 port connectors are also easily accessible.

 

Attachments

· Registered
Joined
·
858 Posts
Discussion Starter · #2 · (Edited)
BTW, I have this wiring diagram. If you look at the CPP, you can see the are a grey and a green/blue. I just need to know if and where I can splice these wires into.


EDIT: I also have the wire colors for the LS2 ECM connectors here:
http://www.ls1gto.com/media/artwork/LS2PCMpinouts.pdf

On page 2, it shows the gray wire being the CPP signal wire. Is this the same for the LS1?
If so, can I tap this to the gray on the switch? Where does the blue/green go?
 

· Registered
Joined
·
858 Posts
Discussion Starter · #3 ·
I think I figured it out. Can anyone confirm this?

I unplugged the connector to the brake pedal, plugged that male end into one female connector on the clutch harness, then plugged the male end from the clutch harness into the original connector I removed from the brake pedal. This is the only way I could see it working.
 

· Registered
Joined
·
7 Posts
The clutch pedal has to sensors on it. I have a 6 inch harness coming off the clutch sensor that’s closest to the fire wall. The other sensor has no harness. I’m just trying to figure out what plugs into that sensor on the top of the clutch pedal. I have an 04 gto that I’m swapping the m6 into.
 

· Registered
Joined
·
1,724 Posts
The clutch pedal has to sensors on it. I have a 6 inch harness coming off the clutch sensor that’s closest to the fire wall. The other sensor has no harness. I’m just trying to figure out what plugs into that sensor on the top of the clutch pedal. I have an 04 gto that I’m swapping the m6 into.
You can look at the a4 to m6 write up. It has all the info needed. One harness will be taped up above the pedals on an auto car. The other plug comes off the brake pedal sensor.
 

· Registered
04/a4 pbm prettygoat
Joined
·
22 Posts
Will the car function without it? Seems like part of the cruise control disable. I have been unable to find it anywhere. I do have an extra rear/firewall side harness which I could build this one out of but I don’t know where they splice into?
Anyway you can make a for dummies version of this? I’m beginning the swap February and think I have everything except this harness.
 

· Registered
Joined
·
1,724 Posts
Will the car function without it? Seems like part of the cruise control disable. I have been unable to find it anywhere. I do have an extra rear/firewall side harness which I could build this one out of but I don’t know where they splice into?
Anyway you can make a for dummies version of this? I’m beginning the swap February and think I have everything except this harness.
The upper switch (closest to you) is the one I need to start on my 04. But I dont use any of them any more as the car is on push start currently.
 

· Registered
04/a4 pbm prettygoat
Joined
·
22 Posts
The upper switch (closest to you) is the one I need to start on my 04. But I dont use any of them any more as the car is on push start currently.
that’s what I’m missing too.
I am finishing up my A4 to M6 swap on my 04 GTO. Some of you may know this if you've seen my other thread.

The only thing that is holding me up is that I can not find the connectors that the clutch pedal position sensor connect to. The switch is pictured. It is the switch on the clutch pedal, closest to the floor. There is about 6 inches of wire that come off the switch and split into two connectors. I've taken out the air ducts and all the trim pieces I can to clearly see the main wiring harnesses down there. I've been searching for where these connectors plug into for weeks now with no luck.

Everyone I've talked to said the A4 and M6 interior wiring harnesses are the same and that I just have to find these connectors. If anyone could PLEASE tell me where these are located, I'd really appreciate it. Heck, I'll even send you some $$ through paypal for your time. I just really need to find where these plug into before I 💣

I really wanted to keep this swap as clean as possible, but I really need to get this car running. If anyone has a wiring diagram or knows where I can splice the wires for this switch to function properly, please let me know. I have the ECM relocated to the drivers side footwell, so those wires are easy to tap into. The BCM and OBD2 port connectors are also easily accessible.

do you have the part number from that harness?
 
1 - 19 of 19 Posts
Top