LS1GTO Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
308 Posts
Discussion Starter #1
I took my car in for service today. I had them replace the clockspring I damaged upon header install, my clockspring was indeed bad, but the dealer called me to tell me that even though my coil was bad and it fixed the notchy feeling, and my steering wheel controls work he said the electronics tech was not there and the tech that worked on it could not find any codes with tech 2, therefore I still get the stupid airbag fault message on my DIC.

The service manager siad it could be a loose wire under the seat or somewhere or a bad airbag and to bring it in next weekend when the electrical tech is there. I doubt it is a loose wire under the seat because I have never even messed with the seats before. I know for a fact that it is when I broke the clockspring that I started getting the airbag fault so I hope that it is not a ruined airbag.

Anyone know why this tech could not find a code with tech 2? I really do not feel like paying the dealer another 80+ dollars for diagnostics any input will be appreciated.
 

·
Registered
Joined
·
308 Posts
Discussion Starter #3
Clockspring as in the thing that has the steering wheel and airbag connections and sits inside the steering column behind steering wheel!!

The clockspring is now fixed but my car is still throwing the airbag fault message in the DRIVER INFORMATION CENTER. TECH2 is the program they use to re-set or delete the airbag codes. But they siad that they could not find anycodes so WTF. Hope airbag is not bad. Hope this informs you or clears things up for ya.
 

·
Registered
Joined
·
308 Posts
Discussion Starter #5
Because I have 61000 miles and have no warranty.
 

·
.. .. .. ..
Joined
·
1,025 Posts
How did you damage the clockspring with a header install?
 

·
Owns 3 GTO's
Joined
·
16,515 Posts
This all depends on what happend during the install. I cannot see you damaging the clock spring. Unless you left the steering wheel unlocked, and the spring unwound. That does not seam to be the case. Do you know any small shops that could put a scan tool on it. A Snap on, or OTC. Both of those will be able to get into your airbag module, and give you some sort of a code. They need to have the updates to work with the 04's, and up. I would do it for you, but, you are a bit of a distance away.
 

·
Registered
Joined
·
308 Posts
Discussion Starter #9
Yes during the headers install my I put the key in the ignition and unlocked it with the rack disconnected, before I could catch it the steering wheel turned about 4 or 5 times before I could stop it but it was too late my coil had broke/unwound. Then when I fired it up it has been giving me the airbag fault ever since. I have come to the conclusion that the dealer just wants another 80.00 out of me since when I talked to him he said I doubt it is your airbag but probably juist a loose wire somewhere so bring it in for diagnostics so we can figure it out. Sounds to me they just want to charge me 80.00 to clear the code cause I think he lied and siad they could not find a code. I have had my car for 2 and a half years and drive 60 miles one way to work so yea it would be nice if it came with a bed.
 

·
Owns 3 GTO's
Joined
·
16,515 Posts
Tell the dealer you want your money back. The original problem was never fixed. That is total BS that they cannot get the code. Sounds more like they either forgot to delete the code, or the problem was really never fixed. Did they put a new clock spring in for you? Did they show you the old one? Did you tell them what you did to cause the problem? What if they forgot to connect the air bag to the spring? They are not one piece. It is very possible. What you need to do is tell them they onw this clockspring, unless they find out why the light is still on.
 

·
Registered
Joined
·
308 Posts
Discussion Starter #11
Well since I researched and knew I damaged the clockspring I ordered one from fred Beans and just took my car up there to have them put it in they left my original damaged one in the passenger seat so they did replace it and my steering wheel doesnt squeek when I turn and my radio controls work but he said that his electronics tech was not there therefore to come back next weekend to pay an additional 80.00 diagnostics fee to see if they can see why there is no code there. If I am still getting the airbag fault on startup then I shoul have a code thrown right? I dont know I will just probably wait and not take it back to them. I am happy as long as my steering wheel contols work and the annoying squeeking noise is gone, anyway I really need to get my 05 bumper and borla exhaust installed so I can finally get tuned and really start having fun with the car ya know.
 

·
Owns 3 GTO's
Joined
·
16,515 Posts
Does the light stay on? Or, does it seam to stay on longer than before? What does your service recipt say about diagnosis time?
 

·
Registered
Joined
·
308 Posts
Discussion Starter #13
The airbag fault message only comes up on startup then I have to press the mode button to get it off the screen and the airbag light in the dash stays on basically They did not clear the code and my reciept does state that no diagnostics for the airbag fault light coming on was performed in great detail and that customer just wanted us to replace the clockspring that he provided to us. But the service manager was probably just talking bullshit when he said that no code was found I even asked him if they went in with tech2 and he said yeah but we coulnt find a code. They were closing in 30 minutes because I had them do an alignment, and flush and bleed my clutch master cylinder.
 
1 - 13 of 13 Posts
Top