LS1GTO.com Forums banner

101 - 116 of 116 Posts

·
Registered
Joined
·
73 Posts
Discussion Starter #102
Maybe it's the stupid ECM.
Or, it could be my stupid ass, lol.

I'll know tomorrow ... or maybe not, seeing as the last time it took almost 1k miles for the issue to pop up again. And after I unplugged it and plugged it back in, it drove fine again. I have a free day tomorrow so I can drive the balls off it. Hopefully it doesn't take a giant poo when I'm far from home. Hehehe ...
 

·
Registered
Joined
·
73 Posts
Discussion Starter #103
Drove just under 100miles in all varying types of driving and all good in the neighborhood. Fingers crossed that it stays this way.
 

·
Registered
Joined
·
73 Posts
Discussion Starter #104
Sorry to bring this back up, but the CEL popped again, this time with the whole gang back together. Lean code in both banks (?), P2135 TPS pedal sensor, P060E and another one I can't remember off the top of my head (it was the same as one of the old ones). Car never went into safe mode though, probably because it came on just as I was rounding the street to pull into the driveway. Drove it again day later and it drive perfectly, though when I started it up again at the store, it had a harder than usual time turning over.

Any layman's way of testing to see if the ECU is bad vs. wiring? When I replaced the pigtail, I checked about 3ft worth of wiring and everything appeared OK. I dunno. Time to call it quits?
 

·
GR-RRR!
Joined
·
4,402 Posts
Could it be being cause by something stupidly simple as a weak battery? Is your battery good and fully charged? Weird stuff can happen with an undercharged battery.
 

·
Registered
Joined
·
73 Posts
Discussion Starter #107
Sucks you have an 05.
Thanks for the sympathy, lol. I know it was a dumb move to get a first year car, but such is life. It's starting to develop a few squeaks and rattles as well. Bah!

Could it be being cause by something stupidly simple as a weak battery? Is your battery good and fully charged? Weird stuff can happen with an undercharged battery.
I suppose nothing is out of the question. But, the CEL did pop up after a 30 mile drive, so I would think the alternator would have done a good job charging it up by that point. The car has always turned over without issue. Today was the first time it had an issue turning over, but in my driveway for its initial start-up, it turned over perfectly fine. I believe I have a voltmeter and I'll check it tomorrow.

What all is involved with an ECM replacement? Does it do a stock re-learn, or do you need to do this at a dealer for them to upload some program or whatnot? I'll probably give the wiring a once over (with my vast knowledge and astute ability to look at different colored wires and have no idea what I'm looking at) before then, but just wondering in advanced.
 

·
Premium Member
Joined
·
35,693 Posts
You can basically get another 05 ecm from a manual car, reprog the vin and do a vats disable, and reflash with your calibration, and you should be golden.
 

·
Registered
Joined
·
73 Posts
Discussion Starter #110
You can basically get another 05 ecm from a manual car, reprog the vin and do a vats disable, and reflash with your calibration, and you should be golden.
Would I need to find someone with HPTuners or something of that sort? I'd prefer to get a new ECM or at least a refurb'd one. Seems that the 05's seemed to have a certain batch that were problematic?
 

·
Premium Member
Joined
·
35,693 Posts
Would I need to find someone with HPTuners or something of that sort? I'd prefer to get a new ECM or at least a refurb'd one. Seems that the 05's seemed to have a certain batch that were problematic?
yeah, hptuners for sure.

you could always send it off to be cloned, or have it repaired. off the top of my head, pcmofnc.com should be able to help you out. 2005 E40's are kind of hard to find, though. i don't see why it isn't possible to use a 2006 E40, but they say you can't. You definitely can't flash the 05 cal or entire to the 06 or visa versa, because there are certain software segments the software will not write that is different between each year model and will only be compatible with the appropriate OS, i believe. i have a 2006 E40 i flashed with the 2006 specific OS, slave OS, and calibration, but with my 2005 VIN and a copypasta tables from my 2005 calibration. i have yet to try it.
 

·
Registered
Joined
·
73 Posts
Discussion Starter #112
yeah, hptuners for sure.

you could always send it off to be cloned, or have it repaired. off the top of my head, pcmofnc.com should be able to help you out. 2005 E40's are kind of hard to find, though. i don't see why it isn't possible to use a 2006 E40, but they say you can't. You definitely can't flash the 05 cal or entire to the 06 or visa versa, because there are certain software segments the software will not write that is different between each year model and will only be compatible with the appropriate OS, i believe. i have a 2006 E40 i flashed with the 2006 specific OS, slave OS, and calibration, but with my 2005 VIN and a copypasta tables from my 2005 calibration. i have yet to try it.
The car isn't a daily, so I can send the PCM out no problem. Is that all that really needs to be done ... a refurbish type deal? Will you still need to go thru the security measures and calibrations if you have it sent out? This stuff is so foreign to me.
 

·
Premium Member
Joined
·
35,693 Posts
I have never had an ecm repaired or cloned, but either way, you shouldn't have to reprogram or link anything. A cloned ECM is an exact copy. Should be plug and play.

Repaired, it's the same ECM, but they replace whatever components took a dump. Hopefully it's not the flash memory that holds the OS or calibration that went bad. If it isn't, i don't see why they would change or clear that memory.
 

·
Registered
Joined
·
73 Posts
Discussion Starter #114
Interesting. The car has been running flawlessly since. Even when the CEL popped, it didn't go into Safe Mode. I guess we'll play it by ear ...
 

·
GR-RRR!
Joined
·
4,402 Posts
If I were you I'd still give the battery a good charging overnight with a good battery charger. If you have a charger that has a reconditioning mode, use it. Charging by alternator honestly isn't the best way to get a battery fully charged. Also, what is the voltage coming out of the battery with the engine off and with the engine running?
 

·
Registered
Joined
·
73 Posts
Discussion Starter #116
After ~20hrs sitting in the garage, battery testing at 12.45V. While running, it tested at 14.51V. Seems to be fine with me, unless that's considered low for an LS2.
 
101 - 116 of 116 Posts
Top