LS1GTO Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
718 Posts
Discussion Starter #1
Ok so i've been experienceing these problems for about a month not and their intermitten so i have not taken it to the dealer since they will most likely say that they didn't notice it.

The first thing is when i try to engauge the clutch from a stop light or after backing out, i get a noise that sounds like something has skipped, not really grinding but more of a grunt coming from the Clutch area. When this happens i get the low traction warning and a little hesitation, it doesn't sound like clutch slipping.

I'm also begining to get the rear diff. whine, is quiet for now.

Sometimes my shifter will jump out of first and/ or second when starting from a stop.

The other porblem i'm having is when i am stopped and turning the wheels from stop to stop i get a nast vibration from the steering linkage, sounds like the box is loose or the tie rods, i'm not really sure. Does anyone else have this?

Thanks
 

·
Registered
Joined
·
335 Posts
Regarding: "get a noise that sounds like something has skipped, not really grinding but more of a grunt coming from the Clutch area"

I get this once is a while. Search for 'can of marbles' this may be what you are hearing.

Regarding: "Sometimes my shifter will jump out of first"

Make sure it is fully engaged. Many time at a light I put it into 1st, twice. The second time I can be sure it is fully engaged. Have never had the problem again. The trans is just a bit clunky.
 
1 - 3 of 3 Posts
Top