LS1GTO.com Forums banner

1 - 20 of 20 Posts

·
Admin
Joined
·
9,705 Posts
Discussion Starter #1 (Edited)
I took another spin in my buddies new 03 Cobra ... I've driven quite a few but it's been awhile going down an industrial road at 90mph with a 6 speed ...

*sigh* the gto will be better, the gto will be better, the gto will be better, the gto will be better, the gto will be better.... ok:) noone has to worry about me going to the darkside.
 

·
LS1GTO Traitor
Joined
·
442 Posts
Been there done that, got the t-shirt to prove it. One word DY - refinement.

If brute force is what you want, the Cobra is a good option.
 

·
LS1GTO Traitor
Joined
·
442 Posts
DevilYellow said:
I havnt banged some good gears since this summer :(
I feel your pain.....and now the snows are coming to the Great White North. Nothing but nice cool dense air comin' to Tampa. I can't wait to get my GTO.....and use up a few thirty-seconds off of the tires on my current sled before selling it. :D

Life is good:)
 

·
13 year owner
Joined
·
16,379 Posts
You realize, that you need to go take a heads and cammed LS1 out now.

I think I hit around 67mph at the top of 2nd at 6,500rpm. :D

It's somewhere around there anyway. I'm too busy watching the tach. :D
 

·
13 year owner
Joined
·
16,379 Posts
Yea, I've heard of some horror stories too.

But then GM isn't exactly perfect either. I've worked in those lanes and had to enforce some warranty denials. It ain't fun telling a customer their hard earned asset won't be covered due to some technicality. :)
 

·
13 year owner
Joined
·
16,379 Posts
Yes. I recall it being a truck. Something like an S-10.

It was readily apparant upon teardown that some other combustive enhancer was used via the residue left. I know a zone rep made the decision. It wasn't mine. I would've covered it as I wouldn't have deemed it a problem.
 

·
^^^^^^^^
Joined
·
434 Posts
well the owner claims he didn't even use octane booster...

but thats what ford have pinned on him and denied warranty on his practacally new $35,000 car.\

Booooo!!!!, seems they are itching at the slightest think to cancel peoples warranties.
 

·
13 year owner
Joined
·
16,379 Posts
Yes and no. There are a lot of other variables involved including the customer themselves. We went above and beyond where we could. We also covered a lot of "performance" work under warranty and if you had bought several vehicles from us, and continued to do so, we also bent the rules some. Whereas if you came in screaming and swinging arms threatening me with bodily harm and getting your lawyers involved, I basically did what I could to enforce every millimeter of the warranty clause.
 

·
^^^^^^^^
Joined
·
434 Posts
DevilYellow said:
UPDATE:

I was 'testing' a buddies 98 Z28 with heads and cam ... full suspension big torque converter .........

lost to an 03 cobra a few times on the street .... we were just playing around, i know he had to have had a puley, his exhaust (catback) was stock...

*sigh*
the heads / cam / converter z28 (LS1) lost to a cobra with pulley and chip ?

i find that hard to believe ...
 

·
13 year owner
Joined
·
16,379 Posts
edsmaroonz said:
head/cam lsi add 40 to 50 hp =350/360/rwhp=tostock cobra at the wheels add pully/chip to cobra =30/40 =almost 400rwhp ??
Really!! Something must be wrong with mine then cause even my conservative heads and cam setup (by todays LS1 heads and cam setups) does 400+ rear wheel HP! There are also tons of 400+ rwhp H&C LS1's roaming around here. Go check out LS1tech....they're a dime a dozen.
 

·
Admin
Joined
·
9,705 Posts
Discussion Starter #16
Being a 98 A4 I think it was in the 400 rang..it's a weird car. A cobra has 400 from factory. A pulley and the HP goes up :D

I have no idea what that car had, but it was at a roll and he was problably in a low gear and at the touch of the gas he hits boost. And I let him make the first hit! oh well... I want my GTO NOW
 

·
13 year owner
Joined
·
16,379 Posts
403rwhp and I ran a 11.87 @ 120.32 last year.
 

·
13 year owner
Joined
·
16,379 Posts
Thanks, It was done right the first time unlike other people I know who had to experiment with several combonations and then when they hit a wall with it and just give up and move onto the next combo. I won't mention any names though (They're not a member of this board btw).

It's a combination of attention to detail and lot of fine tuning I've done on it over the years. I did the heads and cam back in 1999 when there were roughly only three cam grinds available for the LS1. I finally selected GTP's stuff and have been happy since. The car may not make maximum HP numbers like some of the guys that went with the "mountain cams" but around town and in the normal range of RPM's, the thing is just sickenly quick. Most guys stick the cam in with cylinder 1 intake lobe straight up, I degree'd mine 112* advance. I also had a race shop completely balance, blueprint, and bulletproof the bottom end. Then it was tuned on Speed Inc.'s dyno by Jim to it's final 403rwhp rating. I actually extracted that 11.87 when I was lurking in the 392 range. I have yet to run it again cause my rear end is now the weak link and I don't have the spare $$$ to dump into a 12 bolt for it.
 
1 - 20 of 20 Posts
Top