LS1GTO Forums banner

1 - 20 of 30 Posts

·
Deuce and a Half
Joined
·
1,880 Posts
Discussion Starter #1
Hey,

I have this problem where my headlights wont go off. Also i've actually had it where only one headlight was on. This happened after parking the car. The battery was dead in the morning and the headlights wont shut off after i got it started. I am leaving the neg terminal off for now.

Any ideas?

Brad
 

·
I like boobs.
Joined
·
6,581 Posts
Now that is truely odd. Perhaps the control relay for the lights froze up and wouldnt click back off when you turned the lights off. I do believe each headlight gets its own relay which could be why only one light stayed on.

Do you have aftermarket headlight bulbs? (Higher wattage, HID or otherwise different than stock?)
 

·
Deuce and a Half
Joined
·
1,880 Posts
Discussion Starter #3
well they are aftermarket HID kit but the wattage is actually 35 per bulb. That cannot be causing a problem being 20 watts lower. It happened once before and all i did was disconnect the battery.
 

·
Registered
Joined
·
980 Posts
LiqTenExp said:
I have this problem where my headlights wont go off. Also i've actually had it where only one headlight was on. This happened after parking the car. The battery was dead in the morning and the headlights wont shut off after i got it started. I am leaving the neg terminal off for now.

Any ideas?

Brad
Some Ideas:

1. You can pull the key out without the car knowing it. Thus everything stays on.

2. The headlight knob rotary switchy thing isnt exactly clearcut for operation. Maybe you have it in some setting that is meant to leave the lights on?

3. Were you using a sun shield in the windshield and maybe fooled the light sensor?

HTH
 

·
Deuce and a Half
Joined
·
1,880 Posts
Discussion Starter #5 (Edited)
dmonty said:
Some Ideas:

1. You can pull the key out without the car knowing it. Thus everything stays on.

2. The headlight knob rotary switchy thing isnt exactly clearcut for operation. Maybe you have it in some setting that is meant to leave the lights on?

3. Were you using a sun shield in the windshield and maybe fooled the light sensor?

HTH
Ive had the key in and out.
It is in the off position.
no sunshield.

What do you mean when you say you can pull the key out without the car knowing it? Plus anyways if the lights position is in the off position it should be off!
 

·
Great Lakes Moderator
Joined
·
2,358 Posts
I had this happen once about a month after I got my car (probably April). Driving in to work in the morning with headlights on "auto", I noticed they would switch off right as I got to work. One day they didn't switch off before I parked, and I looked out in the parking lot 5 minutes after going into work and they were still on. Ran out and turned the switch to off and they went off. I figured it was a random occurrance where maybe the computer told the lights to go off at the exact time i turned the car off and it had a 'brain fart'. I've never seen the problem since then... good luck!
 

·
Deuce and a Half
Joined
·
1,880 Posts
Discussion Starter #7
Well after screwing around with the relays, taking them out, checking their contacts, then putting them back in and exercising all of them and making sure they closed and released the headlights started working again. I was playing with the foglight ones when this happened. I also noticed that the foglights are attached to the same fuse as the headlights. Anyone have a schematic of the lighting system up front? I would enjoy looking it over.

Thanks,

Brad
 

·
Former GOATilicious SEG lover
Joined
·
2,637 Posts
LiqTenExp said:
Well after screwing around with the relays, taking them out, checking their contacts, then putting them back in and exercising all of them and making sure they closed and released the headlights started working again. I was playing with the foglight ones when this happened. I also noticed that the foglights are attached to the same fuse as the headlights. Anyone have a schematic of the lighting system up front? I would enjoy looking it over.

Thanks,

Brad
See my site :)
 

·
Deuce and a Half
Joined
·
1,880 Posts
Discussion Starter #9
ok now they wont go off again once i got home from my gf house. I am tired of this car. I have had it in for service for 4 different issues now. grrrrr.
 

·
Deuce and a Half
Joined
·
1,880 Posts
Discussion Starter #10
could it be the BCM telling it to keep them on? I have had some weird things like the temp alarm go off and stuff in error.
 

·
I like boobs.
Joined
·
6,581 Posts
I still wonder if the HID conversion has something to do with it. Would it be difficult to switch back to standard bulbs for a day or so and see if it continues to be a problem? Perhaps somehow the light "switch" is set to Auto even though it indicates Off, though that wouldnt make sence why it wouldnt shut off with the key off and out.
 

·
Deuce and a Half
Joined
·
1,880 Posts
Discussion Starter #12
hey jason, from what it looks liek the headlights switch ground to turn on and off right? Well guess what, my hid ballasts were grounding to the chassis it looks like. That would defiantely make them stay on.
 

·
Former GOATilicious SEG lover
Joined
·
2,637 Posts
LiqTenExp said:
hey jason, from what it looks liek the headlights switch ground to turn on and off right? Well guess what, my hid ballasts were grounding to the chassis it looks like. That would defiantely make them stay on.
If you are grounding the circuit on the constant power side (as indicated, the headlight circuit is grounded by the BCM to switch on) by your ballasts grounding to the chassis, that would do it. Did you try to isolate your ballasts?
 

·
Deuce and a Half
Joined
·
1,880 Posts
Discussion Starter #14
Well this is what I wound up doing. Took a trip to Home Depot and came up with these brackets. I glued them to the back of the ballast and then im going to use industrial velcro to secure them to the car. This will insure water doesnt puddle and cause corrosion like it did in my case. I think I might wash my car too much :) That and its been raining a lot. I would definately suggest this to anyone who does these. Just velcroing them down didn't cut it. The part # is incluided in one of the pictures.







 

·
Deuce and a Half
Joined
·
1,880 Posts
Discussion Starter #15 (Edited)
I am going to mask off the ballasts and paint the blue plastic and glued portion so it looks more stock. Should come out nice!

BTW these are the slots you have to cut to make this hid kit work.

 

·
I like boobs.
Joined
·
6,581 Posts
Problem solved? I hope, since I want to do HID's also when i get the goat in a few months. I have pretty bad night vision so I need a lot of light on the road to see well.
 

·
Deuce and a Half
Joined
·
1,880 Posts
Discussion Starter #17
I am 99% sure this was the problem. I noticed corrosion between chassis and the bottom of these ballasts. That means there was electricity flowing. The ballasts operate properly still luckily. I will tell you what happens when they install. The glue i used is aquamarine epoxy so it bonds well to metal and plastic but can take water and salt. The plastic will keep them high enough off the chassis to isolate them and prevent them from sitting in pooled water. This is a definate mod to this mod.

Brad
 

·
Deuce and a Half
Joined
·
1,880 Posts
Discussion Starter #18
Ok heres some pictures of the final product.





To sum this thread up. Be warned with this HID kit of placement. Make sure however you solve this problem that there is no way for them to touch bare or painted metal. Also make sure that they cannot sit in pooled or condensated water. My method is not the quickest but it looks and works like a solid fix in the end.
 

·
I like boobs.
Joined
·
6,581 Posts
Looks good. What exactly is the part you got from the hardware store??
 

·
Deuce and a Half
Joined
·
1,880 Posts
Discussion Starter #20
Its like a recess or riser for a outlet/switch. You can find all shapes and styles in the electrical department. I didn't even have to cut them at all. I got lucky and found something that fits. Plus if you dont want to use velcrow theres screw holes in it.

The part # is A410 from home depot.
 
1 - 20 of 30 Posts
Top