LS1GTO.com Forums banner

41 - 60 of 90 Posts

·
Original Owners Club
Joined
·
9,471 Posts
Boot is on correctly, I may be swinging by the shop where I'm keeping my car today. Will take a closer look and more pics with the trim piece off. May have overlooked it.
 

·
Original Owners Club
Joined
·
9,471 Posts
So the console is the same, I just derped out installing the boot - it fits perfectly now though. :shiner:

Drove the car over an hour today and absolutely love it now, it is a completely different animal with the M6.
 

·
'12-'13 ScrScca SM Champ
Joined
·
7,095 Posts
Going smoothly so far here.
 

·
Registered
Joined
·
507 Posts
Discussion Starter #44
So the console is the same, I just derped out installing the boot - it fits perfectly now though. :shiner:

Drove the car over an hour today and absolutely love it now, it is a completely different animal with the M6.
Hah I was wondering how yours could have been different. Glad to see its going well/went well for you guys!
 

·
'12-'13 ScrScca SM Champ
Joined
·
7,095 Posts
Picked up my M6 parts this week. Just need to decide on a clutch and start putting it back together.
 

·
'12-'13 ScrScca SM Champ
Joined
·
7,095 Posts
Can't get brake pedal out...
 

·
'12-'13 ScrScca SM Champ
Joined
·
7,095 Posts
Is there a way to remove it with out pulling steering column?

All bolts/nuts are out. I can move it all around but can't get it out.
 

·
Original Owners Club
Joined
·
9,471 Posts
Is there a way to remove it with out pulling steering column?

All bolts/nuts are out. I can move it all around but can't get it out.
I had ran into the same issue with my car, ended up pulling the steering column and the pedal assembly came out no problem. Spent too much time trying to manhandle it with the column in, definitely worth the effort of pulling the column.
 

·
'12-'13 ScrScca SM Champ
Joined
·
7,095 Posts
That answers my question.

Column comes out tomorrow.
 

·
'12-'13 ScrScca SM Champ
Joined
·
7,095 Posts
Step one for 05-06 cars to do pedal swap is to pull the steering column. There is no way around it and once it is out of the way everything is easier to get to.

There is also no way to remove the pivot for the brake pedal on a 05-06 car with the column still in.
 

·
Original Owners Club
Joined
·
9,471 Posts
For the guys that have done this, is your reverse lockout always active? I've noticed that my car is always a PITA to get into reverse, and a friend of mine today pointed it that it seems like the reverse lockout is always active which makes it tough to get into reverse.

I do have the ECU flashed already to M6, but I have yet to get the TechII programming done for the BCM/PIM/etc. I'm not sure what controls this function, but I would have assumed ECU.
 

·
'12-'13 ScrScca SM Champ
Joined
·
7,095 Posts
That circuit runs to the dash harness so I assume BCM controls it.
 

·
'12-'13 ScrScca SM Champ
Joined
·
7,095 Posts
Tech2 how to
Body > Instrument Panel > Program > Select Manual Transmission
Powertrain > PIM > Program > Select Manual Transmission

Key still requires T/C button pressed to remove; so I cut blue wire.
 

·
Original Owners Club
Joined
·
9,471 Posts
Tech2 how to
Body > Instrument Panel > Program > Select Manual Transmission
Powertrain > PIM > Program > Select Manual Transmission

Key still requires T/C button pressed to remove; so I cut blue wire.
So you no longer get the "Service Engine Soon" message and your TC/CC works normally? I need to get around to having this done with mine still, just nobody with a TechII around. May end up just paying a dealership for an hour labor to have them sit with me and use their TechII.
 

·
'12-'13 ScrScca SM Champ
Joined
·
7,095 Posts
So you no longer get the "Service Engine Soon" message and your TC/CC works normally? I need to get around to having this done with mine still, just nobody with a TechII around. May end up just paying a dealership for an hour labor to have them sit with me and use their TechII.
Service engine soon is gone.

Setting cluster to M6 kept the Holden display and shift light just turned off the P-R-N-D-3-2-1 display.

TC doesn't work but I believe my p0803 code is causing it to disable. Having it default to off is ok by me.

MPH on the cluster is way off. I'm hoping to fix that with HPTuners.
 

·
Original Owners Club
Joined
·
9,471 Posts
Hmm, I already flashed my cluster to M6 using VZClusterMod - wonder if that will screw things up. With just a M6 tune fine and no TechII programming my speedometer is ok though.

I probably won't be using T/C, but it would be nice to know it works. I would definitely like to have my cruise control back at least.

Last question: So the reverse lockout functions normally now as well?

Thanks for going through and getting the details for the programming. :thumbs:
 

·
Registered
Joined
·
28 Posts
Just finished my swap from a4 to m6 last week, cruise, ABS, both work fine. Flashed an M6 file to my PCM and flashed the cluster aswell. Went to the Dealer to get the TC fixed and they said the Tech2 cant do it and my Vin is locked to A4, Wtf? Can anyone help me?
 
41 - 60 of 90 Posts
Top