LS1GTO Forums banner

1 - 7 of 7 Posts

·
gto architect
Joined
·
158 Posts
Discussion Starter #1
Today I was driving my car normally to get some gas and all of a sudden I lost my brakes. I mean when I push the brake pedal it went all the way down without stopping. Eventually I managed to slowed it down with the hand brake, put it in first and it coasted to a stop. Luckily no car was in front of me. I had my Maggie installed 2 weeks ago. can anyone tell me if this is related in some way
 

·
Premium Member
Joined
·
13,113 Posts
Check the Check Valve that goes from the blower to the brake booster.
 

·
Exhausted Tuner
Joined
·
1,254 Posts
Henry Tong said:
Today I was driving my car normally to get some gas and all of a sudden I lost my brakes. I mean when I push the brake pedal it went all the way down without stopping. Eventually I managed to slowed it down with the hand brake, put it in first and it coasted to a stop. Luckily no car was in front of me. I had my Maggie installed 2 weeks ago. can anyone tell me if this is related in some way
Hmmm ... I would agree with ddawson. Check the brake booster check valve that should have been replaced with the supercharger. if for some reason the check valves sticks or is partially stuck this could be the culprit. While you should NOT have lost the brakes you should have lost the power assist if the vacuum was not there.

Since you are running a complete aftermarket Wilwood brake system checking over the upgraded components should also be a part of your thigns to do.

Glas to hear you are ok.
 

·
gto architect
Joined
·
158 Posts
Discussion Starter #4
Btlfed1500 said:
Hmmm ... I would agree with ddawson. Check the brake booster check valve that should have been replaced with the supercharger. if for some reason the check valves sticks or is partially stuck this could be the culprit. While you should NOT have lost the brakes you should have lost the power assist if the vacuum was not there.

Since you are running a complete aftermarket Wilwood brake system checking over the upgraded components should also be a part of your thigns to do.

Glas to hear you are ok.
I check the front right wheel I think my brake line bursted since there's a puddle of brake fluid there. Does this have anything to do with th install?Or is it just a coincidence that the brake line burst.
 

·
475 Horsepower
Joined
·
204 Posts
My guess is its not related to the Maggie install. I'm glad your ok and no one got hurt.
 

·
Premium Member
Joined
·
13,113 Posts
No unless the installer did something wrong to the line when the water pump was installed. You only have to pull the tire and the brakes are not touched.
 
1 - 7 of 7 Posts
Top