LS1GTO Forums banner
61 - 80 of 106 Posts

·
Premium Member
Joined
·
764 Posts
Discussion Starter · #61 ·
Ok that's what I'd been doing, and it's not always the wb either. A couple times it was vehicle speed that it didn't log.

Anyway I am still getting these kr bumps but they don't seem genuine. I guess I don't know when you'd normally get knock but it doesn't seem like it would be here:
Rectangle Slope Parallel Electric blue Technology


But I don't know enough about it yet to know if the conditions for valid knock are present there. I would have expected it at higher rpm, or maybe when inadvertently lugging it at low rpm. So I'm gonna run a few searches on hpt forum and go from there. At least the fueling is pretty dialed in.
 

·
Registered
Joined
·
2,636 Posts
Ok that's what I'd been doing, and it's not always the wb either. A couple times it was vehicle speed that it didn't log.

Anyway I am still getting these kr bumps but they don't seem genuine. I guess I don't know when you'd normally get knock but it doesn't seem like it would be here:
View attachment 517419

But I don't know enough about it yet to know if the conditions for valid knock are present there. I would have expected it at higher rpm, or maybe when inadvertently lugging it at low rpm. So I'm gonna run a few searches on hpt forum and go from there. At least the fueling is pretty dialed in.
Probably not genuine. You aren't measuring iat either in your table

Hence why I gave up when street tuning with boost. 33% throttle is nothing. If you keep pulling it out, you will end up with no timing which we know isn't correct.

You need a smooth road with no traffic to dial in timing. Idk how a remote tuner can do it
 

·
Premium Member
Joined
·
764 Posts
Discussion Starter · #63 ·
Probably not genuine. You aren't measuring iat either in your table
What do you mean, it's the wrong pid? Or because it's a flat line the sensor is messed up and it's just showing a default? It does change throughout the log slightly here and there. I always attributed it to the xair.

Hence why I gave up when street tuning with boost. 33% throttle is nothing. If you keep pulling it out, you will end up with no timing which we know isn't correct.

You need a smooth road with no traffic to dial in timing. Idk how a remote tuner can do it
I wasn't even working on timing. I just started logging kr after assuming that I had been this whole time. I may just not do anything after verifying that this isn't true knock. All I wanted was to "tune" for the headers and intake and start trying to learn about it.
 

·
Worthless reject member
Joined
·
53,855 Posts
it started to pull timing when dyn air went up. it sounds kinda like burst knock. so the ECM might be anticipating knock because of the sudden change in airflow. so it pulls timing.

i wouldn't pull more timing. i would see how many knock PID's you can log and log them all. (I think there is a burst knock pid?)

once you find out what it is, go from there. You can make the ECM go easy on the anticipative timing pull.
 

·
Premium Member
Joined
·
764 Posts
Discussion Starter · #66 ·
it started to pull timing when dyn air went up. it sounds kinda like burst knock. so the ECM might be anticipating knock because of the sudden change in airflow. so it pulls timing.

i wouldn't pull more timing. i would see how many knock PID's you can log and log them all. (I think there is a burst knock pid?)

once you find out what it is, go from there. You can make the ECM go easy on the anticipative timing pull.
Yes there is. I accidentally closed my graphs to get a better look at my charts and apparently that just completely erases all your histograms if you didn't have em saved, so I'm going to start from scratch on the scanner .
 

·
Premium Member
Joined
·
764 Posts
Discussion Starter · #68 ·
As a test I pulled 5 degrees out of the whole high octane base table, idea being if I still get some retard then it's probably not real. Well I still got some but on the chart it doesn't slowly trail off, but kinda spikes. I don't know what to make of it, I don't even know if I'm viewing the same data in the histogram as the chart. I wish the pids had the sensor number in the name so you knew which one you were using. In my histogram on the last log I got a max of 6.7, but in the chart the highest spike I could find was 3:
 

Attachments

·
Premium Member
Joined
·
764 Posts
Discussion Starter · #69 ·
I don't get it, no matter what I set the chart to it seems to read half of what the histogram and channels list says, it wasn't doing this before. It's like ever since I started logging more knock pids it started dividing it in half for some reason. But that's a separate issue. It seems to me like this test here shows that this isn't genuine knock, but I don't know what to do about it. I guess I'm gonna put the spark table back to stock and just not mess with spark for now.
 

·
Premium Member
Joined
·
764 Posts
Discussion Starter · #72 ·
Should I pull more timing out just as a test? Or maybe pull some out of the low octane base table in case I got some bad gas? At this point I'm not even trying to add timing for performance or anything, I just want to make sure it's not true spark knock and call this tuning journey done for now. Until I do a cam or lsa or something.
 

·
Registered
Joined
·
2,636 Posts
Should I pull more timing out just as a test? Or maybe pull some out of the low octane base table in case I got some bad gas? At this point I'm not even trying to add timing for performance or anything, I just want to make sure it's not true spark knock and call this tuning journey done for now. Until I do a cam or lsa or something.
Nope i wouldnt. In fact i tried that and still got it.

Wasnt worth the headache
 

·
Premium Member
Joined
·
764 Posts
Discussion Starter · #75 ·
Maybe I'll post on hpt forum so I can post full logs.
 

·
The Wulff
Joined
·
2,883 Posts
also, someone who had similar struggles on a G8

 

·
Worthless reject member
Joined
·
53,855 Posts
evs, even though the burst knock PID isn't showing anything, you might try messing with the burst knock settings in the tune anyway, just to see what happens.

there is a base vs cylairdelta table you can fill with lower values, and make some changes to the three multiplier tables that are there. i wouldn't completely eliminate burst knock, just try to dial it down a notch.

there is a "knock sensor tip in - transient mode" area under the "knock sensors" tab that might help if messing with the burst knock settings do not. not something i've ever messed with. just looking at your graph, the knock happens during changes in MAP as well as pedal position.

the pedal position graph is a bit strange, tho. around the knock areas, it's like you're fluttering your foot or something. :ROFLMAO: is that you doing that or the sensor?
 

·
Premium Member
Joined
·
764 Posts
Discussion Starter · #79 ·
evs, even though the burst knock PID isn't showing anything, you might try messing with the burst knock settings in the tune anyway, just to see what happens.

there is a base vs cylairdelta table you can fill with lower values, and make some changes to the three multiplier tables that are there. i wouldn't completely eliminate burst knock, just try to dial it down a notch.

there is a "knock sensor tip in - transient mode" area under the "knock sensors" tab that might help if messing with the burst knock settings do not. not something i've ever messed with. just looking at your graph, the knock happens during changes in MAP as well as pedal position.

the pedal position graph is a bit strange, tho. around the knock areas, it's like you're fluttering your foot or something. :ROFLMAO: is that you doing that or the sensor?
A split second later it shows 6 degrees in the burst knock pid fwiw. I'll have a look at those tables and see if I can make sense of it.

Yeah that's me doing that, I was probably just feathering into first, but I'm not sure why I did it 3 times. After the first time I'm going 1mph, then 4mph after the second time, then I actually start going. Maybe it's my impatience when behind people at a stoplight.

I have been giving it gas while cruising in 6th just to see what it does though and I do get little mini spikes, which I would expect.

I'm still planning on making a thread on hpt forum so full logs can be posted, I'm just trying to make sure I include all pertinent information.
 
61 - 80 of 106 Posts
Top