LS1GTO.com Forums banner

101 - 120 of 149 Posts

·
Repeat LS3 Swapper
Joined
·
191 Posts
Discussion Starter #102
Front bumper quick release latch mount idea is cool. Ease of access to service things and it eliminates the problematic factory piece, win win.
I agree. They were only 26 bucks each, support up to 150lbs, and I figured since I'm not removing the bumper frequently, the push-button mechanism will be free from failure for a long time. Removing 4 screws (2 on top, 2 on the sides) and pushing 2 buttons gets my bumper off! The SAP lower and splitter make the bumper much stiffer/sturdier, so it goes right on and off without issue - I hope that makes sense.

:hbang:

Nice thread, although my neck hurts after looking at all the sideways pics lol
LOL, they have a mind of their own. When I upload them they are the proper orientation, when I post, they have a 50/50 shot.
 

·
Repeat LS3 Swapper
Joined
·
191 Posts
Discussion Starter #103
Some minor upgrades

Took her apart for a few minor mods:



DMS billet manifold. Upgraded this to tidy the engine bay, but peeking inside the OEM manifold, I noticed it is has jagged portions on the inside that could negatively affect flow.



12AN ORB fittings



12AN SS braided hose w/nylon cover

 

Attachments

·
Repeat LS3 Swapper
Joined
·
191 Posts
Discussion Starter #104
I pulled the trigger on a Nick Williams 92mm throttle body. My previous 92mm Warr Performance TB made a LOUD screeching/whistling sound for the first 20-30 seconds of a cold start. RPMS would dart up to around 1100 and it would "cruise control" coming to a stop. It was evident the moment I looked at the Nick Williams that it featured a bigger IAC opening, as well as a small pinhole in the TB blade. The moment I fired the engine up, it had ZERO screech/whistle, and the IAC counts quickly dropped to ~49 counts as the car warmed up. Coming to a stop there were no more cruising, and the idle issues (random surges) were solved - even the VCM scanner showed a more stable idle. I was shocked it made such a drastic difference, but I see why people avoid the "china" TBs. And yes, I adjusted the Warr Performance TB almost weekly and I could never get it right, while the NW throttle body took ZERO ADJUSTMENTS.

Nick Williams on the left, Warr Performance on the right:







 

Attachments

·
Repeat LS3 Swapper
Joined
·
191 Posts
Discussion Starter #105
As everyone knows I absolutely hated my 3" Magnaflow cat-back setup, so I finally deleted the mufflers. I replaced them with 3" Carven r-series mufflers. I will upload a vid with some exhaust clips later today - I have that distinct idle from a LS9 cam again now, it isn't drowned out and quiet like the Magnaflow. Exhaust RUMBLES, and the butt dyno feels something extra. Very pleased, it is just as loud as the Borla ATAKs, but with a deeper rumble.









 

Attachments

·
All Black Everything
Joined
·
843 Posts
How is that fuel pump working out for you? I have the same one and it idles at 55 psi, but drops down to 20 at wot. I have 80lb fuel injector clinic injectors on the stock lines.
 

·
Repeat LS3 Swapper
Joined
·
191 Posts
Discussion Starter #107 (Edited)
How is that fuel pump working out for you? I have the same one and it idles at 55 psi, but drops down to 20 at wot. I have 80lb fuel injector clinic injectors on the stock lines.
61psi idle, 50 wot, returnless stock lines, DW300, FIC injectors that flow 72lbs IIRC (MAP referenced, 60lbs @ 40psi so whatever that is at GM pressure). AFRs are ~11.5 WOT on 91 pump gas, 66% IDC.

I am going to a ATI 10% overdrive and stock upper, with a choppier stage 1 cam, or keeping the LS9 cam and going with a 18% lower and stock upper. I'm debating on going flex fuel sensor and e54. Either way, I'll be staying returnees but opting for Proxes fuel system with DW400.
 

·
Repeat LS3 Swapper
Joined
·
191 Posts
Discussion Starter #108
Welp.. I've heard a lot of "I told you so", but I'm adding a mild cam (mainly for sound), and a 10% lower pulley. Should be just over 600whp on this setup. Haven't decided on the cam, but I do intend on a low lift ~.580 with whatever company I go with. I've spent a lot of late nights in "Mexico", and I've got a lot of footage to throw a new video up so look out for that soon. Power has been great and I've had absolutely zero issues with my current setup, but like I said before, I just want a bit more chop and while I'm down there I might as well throw an overdriven ATI balancer on!



I did the dowel rod cam removal method because it is unnecessary to remove the heads in this case. I'm still on stock LS3 head gaskets, but this new setup should go from 7lbs to maybe 9lbs, tops...? Should be fine. My only other worry is reinforcing the brick (may or may not get to that LOL), and inquiring if I should change from the CTSV Moroso catch can setup I have (with CFM oil cap breather w/ check ball), to something a bit bigger (as far as hose size)..? Any advice welcomed.

 

Attachments

·
Repeat LS3 Swapper
Joined
·
191 Posts
Discussion Starter #109
Well, I ended up throwing the LS9 cam back in. Researched til my head spun, and ultimately decided to stay at an extremely safe 7lbs for now. Didn't want to tamper with meth, new ice box/pump (increased IATs with more boost), move from stock head gaskets, E54, new fuel system etc. all at once. Power is plentiful.

BUT I did install the CTSV/ZL1 ATI harmonic balancer with stock size supercharger pulley
I should've done this long ago! Since I have solid engine mounts, 1pc driveshaft, harrop diff cover, coilovers, redshift trans mount etc, the NVH has increased considerably (but it does not bother me). After the first start up and test drive, I can objectively say vibrations have been cut down by about 75%. I rev to 7k occasionally, and that is where the difference is really apparent - after maybe 5k rpms the car pulls noticeably harder! I know the LS9 cam has its power up top, but after 5k it now feels like boost actually kicks in, it is that big of a difference. Pulls much harder vs the stock crank pulley. Well anyway, here are some photos:











I don't fucking know why the photos always post sideways. Infuriating.
 

Attachments

·
Repeat LS3 Swapper
Joined
·
191 Posts
Discussion Starter #110 (Edited)
Welp, had the #4 intake valvespring break while cruising down the road at 45mph. Car suddenly shut off, and before I realized it shut off, I just so happened to look at my Aeroforce gauge and and see oil pressure go from 28, to 18, to 5, to 0... I panicked! I cycle the key (still rolling at about 35mph) and the car starts then shuts off. I pull off of the road, start the car and it fires right up but I hear very slight clacking and AFRs at 10.9, and at that time I knew what happened - I walked to the engine bay to confirm it was on the passenger side. I purchased these Howards .600" lift valve springs in September 2018, and they had about 6-7 months of run time. Stock 823 heads FWIW. Howards warranty is only 90 days but they asked me to send them back to them and they'll see what they can do for me.



I was 10min. from home so I called my wife to bring some tools and a spare valvespring. I couldn't pry the retainer and locks free so I called for a tow. It was about 110*F in Glendale LOL but a tow came in about an hour. It was a good thing I had bumper Quik-latches because the tow truck winch almost yanked my bumper off!



Yanked it apart that Saturday night, and was relieved to see it barely kissed the piston.



I filled the chamber with brake fluid to verify it sealed. The intake valve had zero nicks or scuffs, as well as the valve guide, so I just replaced the valves springs with a PAC polished dual spring kit that also came with titanium retainers, new seals, locators (s/o to my boy Bryan, his valve spring tool made quick work of the swap). I ran stock gaskets, but took this opportunity to throw some LS9 head gaskets in. Also, my ARP bolts paid for themselves since they are reusable lol



Plugs looked good and only had about 8k miles, but I replaced them and took the gap down to .035" this time. It may be all in my head but the car feels stronger.

 

Attachments

·
Repeat LS3 Swapper
Joined
·
191 Posts
Discussion Starter #111
I am running a Moroso catch can but there was a small amount of oil pooled in some parts of the blower, and the whole thing has a slight sheen. Moroso catch can does catch a ton of oil, but I've thought about venting to the atmosphere. Brick is not reinforced and is in perfect condition with zero signs of collapsing, so I washed it and reinstalled it (only 7lbs of boost).



Got the OTR filter cleaned and re-oiled.



Got it all together and running yesterday. Was a long two days.



Drove it this morning about 80 miles, between the ATI, new regapped plugs, cleaned filter, it drives completely different.

 

Attachments

·
My other car has wings
Joined
·
440 Posts
Good thing you didn't have your foot into it when that spring let go....could have been much worse!
 

·
Repeat LS3 Swapper
Joined
·
191 Posts
Discussion Starter #113
Good thing you didn't have your foot into it when that spring let go....could have been much worse!
Exactly! I was shocked they broke, but Frank Beck from BRE stayed open a bit later so I could pick up a spring kit from him. He says he sees it all the time and it is the reason he only uses PAC.

Guess I tried to be cheap and paid the price. Even with just a LS9 cam.

Is it because the heavier valves of the 823 heads? Boost put more stress on the intake valves? Shit luck? Guess I'll never know lol I dodged a big bullet.
 

·
Repeat LS3 Swapper
Joined
·
191 Posts
Discussion Starter #115
What aspect ratio rear tires are you running, I couldn't see it listed in your thread. 35? They look beefy!
275/40/19 super sports
 

·
Repeat LS3 Swapper
Joined
·
191 Posts
Discussion Starter #117

Attachments

·
Repeat LS3 Swapper
Joined
·
191 Posts
Discussion Starter #118
 

·
Registered
Joined
·
120 Posts
Two things.

1. How the heck do you get the Youtube video to embed like that? I have been trying.

2. Dang it, do all that stuff to the GTO instead! I was enjoying your build.
 

·
Repeat LS3 Swapper
Joined
·
191 Posts
Discussion Starter #120
Two things.

1. How the heck do you get the Youtube video to embed like that? I have been trying.
I just copied the address bar when viewing my video

2. Dang it, do all that stuff to the GTO instead! I was enjoying your build.
Got bored (bad when you're an impulsive person). The z32 on the other hand has a bottomless pit in aftermarket options. I'll be entertained for a while.
 
101 - 120 of 149 Posts
Top