LS1GTO Forums banner
1 - 3 of 3 Posts

·
donde esta la biblioteca
Joined
·
319 Posts
Discussion Starter · #1 ·
Does anyone know the part number to the IAT sensor on a magnuson TVS 2300??

continue reading if you would like the back story.

I had a magnuson S/C installed a few months ago and obviously tuned at the time of install. When i first picked it up after the install, the CEL light would flash at random times but seemed to happen more frequently while the car was idleing for longer periods of time.
I never really paid much attention to it because it would always shut off.

Fast forward to today, the CEL light came on and stayed on. I happened to look at my vehicle monitoring display, and it showed my IAT at 302.00F. I think I might have an issue with my IAT sensor on the S/C lol. I looked under the hood and found that the sensor hold down was actually sitting on the wire. I didn’t move it or anything yet, but it’s a funky looking sensor. I figure this would be a good place to start and see if it fixes the issues, but does Anyone happen to know the part number for the sensor??
Automotive fuel system Automotive tire Automotive lighting Motor vehicle Rim
 

·
donde esta la biblioteca
Joined
·
319 Posts
Discussion Starter · #3 ·
Not gonna lie….sounds like a real kick to the nuts lol. I’m gonna call magnuson and the installer and see if there’s something they can do, it’s only been in the car for 6 months.

If nothing can be done what’s involved with doing this?? I’m going to try and find some posts about it but do you have any input?? Sounds like it might a be a decent project.
 

·
donde esta la biblioteca
Joined
·
319 Posts
Discussion Starter · #5 ·
When you say you relocated the IAT, are you saying you relocated it to the same hole the wires are coming out, or is there a different hole??
 
1 - 3 of 3 Posts
Top