LS1GTO Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
I'm not an expert on car's,but my goat is idling really strange.It has sporadic rough idle. It idles smooth for a few seconds then feels like someone lightly shakes the car, then runs smooth again. I'm sure it has to do with the timing,but no service engine light yet. Has anyone else had this problem? I'm going to take it to the dealer,as much as I don't want to,cause they'll probably screw it up worse. Is my goat gonna die on me? :confused:
 

·
Registered
Joined
·
54 Posts
Uhh, I think that lope in the engine is deliberate :) It harks back to the big-cammed V8's that'd literally shake your fillings out ...
 

·
Registered
Joined
·
121 Posts
Elves snuck into your garage in the middle of the night and installed a performance cam. Happens all the time, nothin to worry about. :)
 

·
Registered
Joined
·
392 Posts
Six speed, My Goat does the same thing. Being in California I thought of a small earth quake!!! It has done it since day one. Since no check engine light I'm not concerned. My Goat is running fine. Check with dealer but I have my doubts with it being a new product. We have pleanty of factory coverage!!! Is your Goat an auto??

GET Back... COSMO
 

·
13 year owner
Joined
·
16,384 Posts
Same here, simple cam lope.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #9
LOPE!! , of course. Except now I feel like a DOPE!!
Thanks guys,I didn't know this car had a bigger cam than my SS camaro,that's awesome!
 

·
Moderator
Joined
·
3,327 Posts
Feels good now, doesnt it?
 
1 - 10 of 10 Posts
Top