LS1GTO Forums banner

1 - 19 of 19 Posts

·
Captain Thread Killer returns
Joined
·
21,898 Posts
Discussion Starter #1
I finished installing my JBA headers this morning and after starting her up and lettting her run for a couple minutes I am getting this white smoke coming from below the engine? It smells wierd too like something is burning?? Any thoughts? I am getting ready to crawl under and see if maybe I did not tighten the downpipe bolts enough.......other than that i dont know what else it could be...... :banghead:
 

·
Big Daddy Says
Joined
·
1,992 Posts
Dbluegoat said:
I finished installing my JBA headers this morning and after starting her up and lettting her run for a couple minutes I am getting this white smoke coming from below the engine? It smells wierd too like something is burning?? Any thoughts? I am getting ready to crawl under and see if maybe I did not tighten the downpipe bolts enough.......other than that i dont know what else it could be...... :banghead:
maybe a coating applied after manufacture? let it run a bit and see if it clears up???
 

·
Registered
Joined
·
245 Posts
Did you clean the headers after you installed them? You will definitely get a lot of skin oils/grease/etc on them during installation usually, so it could be that. Been there, done that...smells bad! Don't know, just throwing that out there...
 

·
Captain Thread Killer returns
Joined
·
21,898 Posts
Discussion Starter #4
GTO4Ever said:
maybe a coating applied after manufacture? let it run a bit and see if it clears up???
I was thinking maybe that too, but I am afraid to let it run too long if something is burning..... I dont know this was the first time I ever put headers on.
 

·
Big Daddy Says
Joined
·
1,992 Posts
Dbluegoat said:
I was thinking maybe that too, but I am afraid to let it run too long if something is burning..... I dont know this was the first time I ever put headers on.
i'd bet it was some kind of coating, 15-20 minutes of run time will get rid of it.... as long as it doesn't smell like wire, plastic or oil.....
 

·
ya im french what of it !
Joined
·
800 Posts
there should be some burning off of stuff on the headers its fairly normal.

i have installed alot headers some smoke bad some are fine. as long as u dont see anything touching them your ok..let it smoke let it run let them get hot .

it will burn off and clear up
 

·
Can't help ya, Sorry.
Joined
·
14,481 Posts
Unless it smells like rubber then you are likely Ok. Did you use any grease or oil on anything? Likely that will be going up in smoke. New exhaust work always smokes a bit. There is always some oil or grease on something to burn off. With out being there to smell the smoke I can't tell exactly what it is. 95% chance of everything being fine
 

·
Captain Thread Killer returns
Joined
·
21,898 Posts
Discussion Starter #8
sxty8goats said:
Unless it smells like rubber then you are likely Ok. Did you use any grease or oil on anything? Likely that will be going up in smoke. New exhaust work always smokes a bit. There is always some oil or grease on something to burn off. With out being there to smell the smoke I can't tell exactly what it is. 95% chance of everything being fine
ok thanks everyone, I will let it run for a bit. No oil or grease at all. It almost smells like a plastic but I see nothing touching, its kind of a white smoke too, not a whole lot but I did not let it run long either. I will be back in a few minutes
 

·
Can't help ya, Sorry.
Joined
·
14,481 Posts
Were they wrapped in plastic or maybe a piece of tape that held the wrapping on? follow them down and make sure there are no wires resting on them.
 

·
4L60E+moded ls1+saudi = bad
Joined
·
710 Posts
its kinda normal but you'd better make sure and check for leaking. i know its rare but **** happens! please check the headers/heads for any leaks. otherwise its all normal.
 

·
Can't help ya, Sorry.
Joined
·
14,481 Posts
Good thought but I have never had an exhaust leak smell like plastic...
 

·
Captain Thread Killer returns
Joined
·
21,898 Posts
Discussion Starter #13
ok I double checked again and saw nothing rubbing, the first plug on the pass side does touch the header but it has the heat shield on it. Do you think I should put the heat shields on all the plugs? I guess I was overreacting since I am not a gear head and this is a new thing for me. The smell does seem to be a new metal smell or something cant really describe it. I let it run for almost 15 mins and the smell seems to be going away and I did not see anymore smoke. Thanks guys, I get scared when something is not right with my baby.
 

·
Captain Thread Killer returns
Joined
·
21,898 Posts
Discussion Starter #14
04redgto said:
hey d can you take some pics i should be installing the JBa's next week.
I got some and will take a few more, you doing this by yourself? I will prepare a little post on some of the most pain in the ass parts of the job. I did take about 6-8hrs but I went slow and was learning along the way. I was able to do the job without lifting the engine.
 

·
KBAS
Joined
·
221 Posts
OK... now that the smoke is clear, did your headers change color? I haven't seen any pics of those headers after being run. I hate it when they get that blued rainbow look.
 

·
Can't help ya, Sorry.
Joined
·
14,481 Posts
Dbluegoat said:
I guess I was overreacting since I am not a gear head and this is a new thing for me. The smell does seem to be a new metal smell or something cant really describe it. I let it run for almost 15 mins and the smell seems to be going away and I did not see anymore smoke. Thanks guys, I get scared when something is not right with my baby.
Anytime. No overreacting, the first time is a bit weird when it smokes. You just learned a bit that's all.
 

·
Big Daddy Says
Joined
·
1,992 Posts
Dbluegoat said:
I got some and will take a few more, you doing this by yourself? I will prepare a little post on some of the most pain in the ass parts of the job. I did take about 6-8hrs but I went slow and was learning along the way. I was able to do the job without lifting the engine.
best way to learn, first set of headers i put on "69 SuperBee" thought i was buring the car down on the first run, scared the Poop outta me.....

glad it all worked out...
 

·
4L60E+moded ls1+saudi = bad
Joined
·
710 Posts
sxty8goats said:
Good thought but I have never had an exhaust leak smell like plastic...
lol i know but sometimes when the headers leaks, it heats and burn everything plastic around
 
1 - 19 of 19 Posts
Top