LS1GTO Forums banner

1 - 20 of 138 Posts

·
Registered
Joined
·
1,191 Posts
Discussion Starter #1
Busted a wheel recently so now everything is suspect, have the same gap on both sides. BC coilovers

507670
 

·
Registered
Joined
·
1,191 Posts
Discussion Starter #4
But they’re poly, bro!

Seriously tho, they have 10K on them. Doubt it’s from the wheel bending incident since both sides have the same gap.
No weird noises aside from the clunk on pass side when stopping.
This sucks a little. Just got it aligned, will have the shop check camber once replaced since I doubt anything else will change.
Thx
 

·
Premium Member
Joined
·
1,116 Posts
I doubt its from the incident either. Just something youre noticing now that youre overlooking.

Idk that youd need to get realigned. It may change a little with a new mount but i cant imagine that much. Could be wrong..
 

·
Worthless reject member
Joined
·
46,561 Posts
But they’re poly, bro!

Seriously tho, they have 10K on them. Doubt it’s from the wheel bending incident since both sides have the same gap.
No weird noises aside from the clunk on pass side when stopping.
This sucks a little. Just got it aligned, will have the shop check camber once replaced since I doubt anything else will change.
Thx
it's because GTO.

it happens.
 

·
Worthless reject member
Joined
·
46,561 Posts
oddlly enough when i swapped my stuff out for GForce1320 coilovers on red a year or two ago, with about 35k miles on the odo and well over a decade on the struts and mounts since they were original, and the strut mounts were not collapsed.

put in a set of kyb mounts on my blue car, bam, collapsed in about 6 months and hardly any driving.
 

·
Registered
Joined
·
1,191 Posts
Discussion Starter #10
Gonna see if I didn’t mess something up in the install process as a newb. I remember not installing a conical type plate on top, I think, idk, been a while but do remember being confused about where it went during install.
I don’t have any weird up/down noises and it may have been like this since I put it all together.
Assembly is straightforward but if there’s a slight chance for me to mess something up I’ll likely do it:

507674
 

·
Registered
Joined
·
1,191 Posts
Discussion Starter #12
No, that just some exploded view I found from eBay. Didn’t mean to confuse.
Saved it for reference for when I get to reviewing it.
 

·
Registered
Joined
·
340 Posts
I had the same issue with mine about 6 months ago. I replaced the strut mounts and bump stops. The bump stops were shot too. I would replace those too while you have it apart.
 

·
Premium Member
Joined
·
1,116 Posts
I have the coilover install on my laptop if you want to see how it should have been installed. Either way you should pull them to replace the collapsed mount
 

·
Registered
Joined
·
1,191 Posts
Discussion Starter #15
I had the same issue with mine about 6 months ago. I replaced the strut mounts and bump stops. The bump stops were shot too. I would replace those too while you have it apart.
Where are said stops?!? I was looking for those when assessing damage and couldn’t figure out where they were.
 
1 - 20 of 138 Posts
Top