LS1GTO Forums banner
1 - 5 of 5 Posts

·
Power in paradise
Joined
·
373 Posts
Discussion Starter · #1 ·
DISCLAIMER: This is observational on my part and not scientific. I am not a mechanic - but welcome comments from those more expertise in these matters.

Have had a Predator for some time, and have regularly updated the software - most recently to R99. I noticed a week or two ago a very noticeable and alarming clunking the the drivetrain when slowing to a stop. Felt like a rought downshift - or otherwise mechanically noisy clunk. Could not really figure out if it was the diff... or the trans... or something else (like driveshaft?). So rather than go about messing with fluids or other changes, decided to just revert to stock tune for a bit (as it took a while for the clunking to start) and see what happened. As the car "relearned" with the stock tune, I was very surprised when the clunking disappeared! Interesting!

With this new data in hand, I loaded up the R97 tune to see what would happen. A good week later - no clunk. I have saved most of the tunes since R93 so it was easy to just go back a reload a prior firmware.

My conclusion - R99 has done something with shift firmness or otherwise something new with the trans. That's the only thing I can figure... unless someone else has a different interpretation or experience themselves. I have seen a few threads on clunking and don't know if Predator tunes are in the equation or not - but thought this worth noting to the community.

Cheers!
 

·
Retired LEO meow
Joined
·
14,535 Posts
I have my parameters set up very aggressive and have had absolutely no problems.
-Increased WOT pressure/partial throttle pressure +25%
-Increased speed of shifts +25%
-Removed TM.
-Changed shift points from 5900 rpm's to 6100 prm's.
 

·
|G|et |T|urned |O|n
Joined
·
1,631 Posts
Chris-
I'm running R96 or 97, cant remember which... and would say I have no problems whatsoever with it.

When I disengage or engage the clutch, I sometimes get a subtle clunk-type-sound, but I am fairly certain this is totally normal for an M6's clutch action.

Maybe it is something with R99... but, Diablo told me that there are NO GTO updates within that rev. Updates are only for V8 Grand Prix / Monte compatibility.

hope that helps...


National :pir_flag: day today! Arrrrgh!
 

·
Registered
Joined
·
126 Posts
Diablo r99

the Diablo r99 is not for the GTO... it is for monte carlo and several other GM products. You should use the r97
 

·
Power in paradise
Joined
·
373 Posts
Discussion Starter · #5 ·
robo282 said:
the Diablo r99 is not for the GTO... it is for monte carlo and several other GM products. You should use the r97
Really? Have you looked at the Diablo page?

http://diablosport.com/index.php?module=htmlpages&func=display&pid=68

MIAGTO said:
Maybe it is something with R99... but, Diablo told me that there are NO GTO updates within that rev. Updates are only for V8 Grand Prix / Monte compatibility.
MIAGTO - Yes - I thought that to be the case as well (no change for GTO in R99), but actual behavior seems to contradict that. I thought R93 was very stable and I had a great UOA using it... Might just go back to that version!
 
1 - 5 of 5 Posts
Top