LS1GTO Forums banner

1 - 19 of 19 Posts

·
Yellowjacketfever
Joined
·
479 Posts
Discussion Starter #1
my son has a cavalier that he put a 50 shot on and is running 14.4 thru the qtr. yesterday he lost the compression rings on#2 cyl, i told him that the stock rings would not hold up to hitting the system very often. he has 40.000 miles on car. what i would like to know is will the nitrous do this to a stock engine if you throw alot of nitrous to it. i will not put it on my 04 goat if this happens alot. or do our cars have better rings in them. hope i came to the right thread.
 

·
got goat milk?
Joined
·
361 Posts
is he tuned? im guessing he is running a dry shot of nitrous. sounds like he leaned out. a properly setup/tuned nitrous car will last a very long time.
 

·
Registered
Joined
·
414 Posts
yes, I'll second that, a friend of mine ran thru 100 bottles thru his LS1 camaro, never had one problem....
 

·
Bann3d
Joined
·
6,043 Posts
+1 I would said lean condition and tuning issue, maybe some spark problem,
I ran 6 bottles through my stock bottom end car this weekend on a fairly big wet kit and checking all the plugs and compression this morning everything is perfect.
 

·
Single Digit Stick Shift
Joined
·
4,088 Posts
slowgoat said:
I ran 6 bottles through my stock bottom end car this weekend on a fairly big wet kit and checking all the plugs and compression this morning everything is perfect.

Man, that sounds like a fun weekend. :turbonaug :gears:
 

·
its only a 5.7 its the slow1
Joined
·
1,241 Posts
BillyGoatGruff said:
Man, that sounds like a fun weekend. :turbonaug :gears:
x2!! lol i have been through about 15 since a month agao andit still running hard lol
 

·
Single Digit Stick Shift
Joined
·
4,088 Posts
I thought a 15#er a week was bad, you guys are just junkees. :drink:
 

·
Bann3d
Joined
·
6,043 Posts
alot of that was tuning partial passes, and knowing that my car was capable of making a 120mph pass in the 11.5? range. And actually 2 of the bottles were not filled the greatest and caused the car to run funny,
 

·
Single Digit Stick Shift
Joined
·
4,088 Posts
slowgoat said:
alot of that was tuning partial passes, and knowing that my car was capable of making a 120mph pass in the 11.5? range. And actually 2 of the bottles were not filled the greatest and caused the car to run funny,

How were your 60's?
 

·
Bann3d
Joined
·
6,043 Posts
the car 60ft. 1.64-1.66 all day long with the bottle not coming on until approx. .7 out. I notice the PCM isn't letting the progressive controller know that its WOT for a split second at the hit. The car leaves great then you can feel the extra pull about 25ft. out.
 

·
Can't... stop... modding...
Joined
·
929 Posts
LS1's and LS2's LOVE nitrous - don't base your nitrous decision on what happened to a Cavalier.

The tune is everything... if not for safety, for power. The wet 150-shot on my '05 was actually REALLY rich, and was safe, but not as powerful... we picked up approximately 40rwhp by just leaning the car out - and it was still safe.
 

·
Yellowjacketfever
Joined
·
479 Posts
Discussion Starter #12
ok i forgot to say that he put the shot about a half inch from the t/b. everyone has told me that it was a wet shot. and his car is stock everything. all he has done is put a full cai on it and plugs that were for nitrous. i am not that great and don't know enough about it. i can tell you that his car was running rich as the tail pipe was allways black and you could smell it flooding or a rich unburnt gas smell. he said it started missing on one cylinder and went to two then three and he parked it and thats when he noticed it had a miss. i pulled out the #2plug and you can see a piece of a broke ring on top of the cylinder. and he has ran a good 30 bottles thru it, before it went bang. his father inlaw has a nitrous refueling station at his house, so he gets all he wants for free. i guess that is not a bad thing but in his case it was. he should have gotten a tune done after he put the nitrous on and he would proably still be running. thanks for the input.
 

·
Bann3d
Joined
·
6,043 Posts
Guess it could be a number of things, Like in my car it was getting a lean spike at the hit from the nitrous getting to the engine just before the fuel was
Also running was to rich is just as bad as being lean, To much timing maybe creating some knock, Who knows could just be the engine itself and the nitrous not even being the cause of the problem..
 

·
its only a 5.7 its the slow1
Joined
·
1,241 Posts
my dad owns a junkyard here in hialeah and we sell newer style cavelier motors almost evry two days ...only good motor that gm makes are these v8's and ohh cant forget that gn motor
 

·
Yellowjacketfever
Joined
·
479 Posts
Discussion Starter #15
well i know around here those ecotec 2.2 are very good as long as you fix them up like you are supposed to. again thanks to all, sounds like a lean proablem. but who will ever really know.
 

·
Can't... stop... modding...
Joined
·
929 Posts
It actually might not be a lean problem. The only other reason it might have been a lean problem is that the fuel pump couldn't keep the pressure up to supply adequate fuel per amount nitrous. A dyno-tune and a good tuner would have noticed this, though.

Other than that, most wet systems' suggested jets are perfect for the nitrous/fuel mix... Like above, though - I also had a lean spike when I first hit it. Relocating my fuel solenoid 4" from the plate (nozzle) fixed that. Lean spikes are no good, and I'd much rather run rich for a split second than lean for a split second.
 

·
Bann3d
Joined
·
6,043 Posts
+1 on a potential lean spike I had to shorten my fuel line by 6 inches to get rid of the problem, and you can definatily feel it 4 or 5 quick spudders or jerks in a slip seconds time
 

·
Yellowjacketfever
Joined
·
479 Posts
Discussion Starter #18
when he got the system it had what he called a brain i think. he said it would not put any nitrous into the engine unless there was adequate gas. but there proably was a leaning when it was activated.
 

·
Can't... stop... modding...
Joined
·
929 Posts
..........oh...........

I've heard terrible things about those "smart" systems. I think Zex made one that was particularly prone to hurting engines with their "fuel control" thing...
 
1 - 19 of 19 Posts
Top