LS1GTO Forums banner

1 - 6 of 6 Posts

·
Murphy the RMGTO Mod Dog
Joined
·
3,500 Posts
Discussion Starter #1
I am installing a hardwire setup for my radar detector, and Passport 8500. The install kit says nothing more than find a 12V+ source. So I am following this install how-to-do:

http://gtohq.atspace.com/html/body_radar_detector_hardwire.htm

I got all the wires routed, and then tapped into the fuse as shown in the guide. I have tried sticking anywhere from and 1/8" to a 1/4" of bare wire into one side or the other of the fuse slot, just like the pic below. I am not getting the radar detector any power though. My plug in the center console still works.



Any suggestions?
 

·
Murphy the RMGTO Mod Dog
Joined
·
3,500 Posts
Discussion Starter #2
NM, got it to work.
 

·
Oh my f*ck!
Joined
·
6,464 Posts
Helpful hint:

No disrespect to the person who wrote that how-to but sticking a bare wire in a fuse receptacle is just lame.

Buy an "add-a-circuit" and some splices from your local Autozone, Pepboys, Kragen, etc. They're a few bucks and it'll look a lot more professional, not to mention the fact that the radar detector will then be fused as well. As it stands, if something goes wrong, bad news.

EDIT
Read: http://www.ls1gto.com/forums/showthread.php?t=3255
 

·
Murphy the RMGTO Mod Dog
Joined
·
3,500 Posts
Discussion Starter #4
The hard wire for the radar detector has an inline fuse. So figured it be safe.
 

·
Registered
Joined
·
561 Posts
I have an Escort 8500 also, but I tapped into the cell phone plug behind the passenger kick panel. Also used it to power my Sirius Plug and Play unit.
 
1 - 6 of 6 Posts
Top