LS1GTO Forums banner

1 - 8 of 8 Posts

·
UNDER REPAIR! FROM BAD CRASH!
Joined
·
122 Posts
Discussion Starter #1
I had my GTO parked in my driveway for 3-4 days in the so.FLA. weather (rain) & drove my other car & when I moved the GTO I noticed rust stains on the driveway. Only on the drivers side 4 spots about 1 foot in from the wheel line. What can this be??? I looked under & didn't see anything. I moved the car & spots again....same side same distance in on the drivers side.. Im stumped? Has anyone had this problem?:confused:
 

·
I hate NASCAR
Joined
·
788 Posts
Was it near the wheels themselves? My rotors rust like a biotch when they get wet. Might have dripped from the rotors when water dripped down onto the wheel and onto the pavement to the inside?
 

·
1 of 40,757
Joined
·
6,482 Posts
Yeah my guess would be the rotors. Rust builds up quick on them and then a rain or morning dew will carry some of it away leaving some rust residue on the pavement.
 

·
Just a Re-engineered Cavalier
Joined
·
2,244 Posts
My car hasn't been driven in 1.5 days since I drove it in the rain. The rotors have rust and crap all over them. That would be my guess
 

·
Five-0 GTO
Joined
·
36 Posts
I had the same problem, noticed rust stains on the garage floor in between the front tires couldn't figure it out. Two weeks ago I go to pull the t/b to port it I happened to look at the battery tray and at the bottom it looked like battery acid, upon a closer look battery acid had leaked out of it all over the inner fender well on a wire harness and onto the frame rail then dripping on the floor. Called the dealer right away and took it in, had the battery, tray,wire harness replaced and inner fender repainted. Hope its just rust not a cheap & crappy battery.
 

·
1 of 262
Joined
·
10,335 Posts
My rotors rust inside the venting so every time they get wet, I get puddles of rust colored water. I wish the rotors were stainless.
 

·
UNDER REPAIR! FROM BAD CRASH!
Joined
·
122 Posts
Discussion Starter #8
Update

WELL...its not the rotors. It's inboard of the rotors and only on the drivers side. It looks to me that the rod from the frame to the lower control arm is the culprit. The front part that has the threads & nut is verry rusty & is in the rite spot for the drop on the driveway. Im going to wire brush it & paint it with black rust paint & see if it stops. I will keep everyone posted.:patriot:
 
1 - 8 of 8 Posts
Top