LS1GTO Forums banner
141 - 158 of 158 Posts

·
GR-RRR!
Joined
·
6,799 Posts
negative. just waiting it out. dont want to be one of those people
I just hope they are making a few in a batch instead of dinking along one package at a time. Its only been a week for me and I'm already frustrated! ;) At least I have a few smaller prepatory projects to keep me busy for a short while. Steam vent tube for the rear is tonight's engineering experiment. Hope the parts store can help me out with the proper kind of hoses and a t-fitting to match.
 

·
Premium Member
Joined
·
1,810 Posts
Discussion Starter · #146 ·
I just hope they are making a few in a batch instead of dinking along one package at a time. Its only been a week for me and I'm already frustrated! ;) At least I have a few smaller prepatory projects to keep me busy for a short while. Steam vent tube for the rear is tonight's engineering experiment. Hope the parts store can help me out with the proper kind of hoses and a t-fitting to match.
They do make them in batches according to their email. Not sure how many though.

Ill be curious to see what you end up with. Keep in mind the lower manifold to the TVS butts out towards the rear
 

·
GR-RRR!
Joined
·
6,799 Posts
They do make them in batches according to their email. Not sure how many though.

Ill be curious to see what you end up with. Keep in mind the lower manifold to the TVS butts out towards the rear
Yeah, so does my FAST. I found pictures of the manifold by itself online and it has a relief built in where the steam line fitting will go. It doesn't look any more obstructive than my FAST so I'm thinking if I can make it fit with the FAST, it should fit with the Maggie.
 

·
Premium Member
Joined
·
1,810 Posts
Discussion Starter · #148 ·
Yeah, so does my FAST. I found pictures of the manifold by itself online and it has a relief built in where the steam line fitting will go. It doesn't look any more obstructive than my FAST so I'm thinking if I can make it fit with the FAST, it should fit with the Maggie.
Ah please post pictures in your thread id like to see what you get figured out
 

·
Premium Member
Joined
·
1,810 Posts
Discussion Starter · #152 ·
Feel like im twiddling my thumbs over here.

Waiting for a radium check valve to show up at least. When i first put the pump in it seemed to hold pressure in the line after priming. Now it drops immediately, not sure what happened. Just going to put the checkvalve before the fuel filter
 

·
LS9 FTW
Joined
·
294 Posts
TOARKS!!!!!!!! Congratulations on getting your kit on!
 

·
Premium Member
Joined
·
1,810 Posts
Discussion Starter · #157 · (Edited)
im getting rid of the canbus oil pressure gauge because id rather have my obd2 ultragauge display. the oil pressure wont work at the same time and i can always read it in the vcm scanner if i wanted to check. swapping in a fuel pressure gauge so i can verify it is rising rate in boost.

still deciding on a dual cluster pod for widebands in each bank
 

·
Premium Member
Joined
·
1,810 Posts
Discussion Starter · #158 ·
Wet okole seat cover installed on the driver seat tonight. They are nice covers. Not my favorite look but beats a torn seam and leather ripping through for now
 

Attachments

141 - 158 of 158 Posts
Top