LS1GTO Forums banner
21 - 28 of 28 Posts

·
Registered
Joined
·
587 Posts
Check fuses to see if 1 blew. I had this happen to me once a few years back. Pulled into a gas station car running fine, went to start to leave and nothing. Was able to kick start it and get it home with the help of a few ppl there to push. Ended being a blown fuse under the hood.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #23 ·
Check fuses to see if 1 blew. I had this happen to me once a few years back. Pulled into a gas station car running fine, went to start to leave and nothing. Was able to kick start it and get it home with the help of a few ppl there to push. Ended being a blown fuse under the hood.
Noted, will do, happen to remember which one it was by chance?
 

·
Worthless reject member
Joined
·
49,289 Posts
wonder if a segment swap from the 06 to 05 ecm would correct that problem.
If it really is a hardware difference between the 05 and 06 ECM, wouldn't that brick it? Like i said before in my 29 page rant on ECM's above, I would think you need to stick with the right ID's or service #'s for the main and slave OS for your year ECM.

I guess that the E38 slave OS was the one that was unaccessable by Hptuners, btw. It may br now with a newer version, not sure. My swiss cheese brain likes to swap details around or skip over stuff for some reason.
 

·
Worthless reject member
Joined
·
49,289 Posts
Check fuses to see if 1 blew. I had this happen to me once a few years back. Pulled into a gas station car running fine, went to start to leave and nothing. Was able to kick start it and get it home with the help of a few ppl there to push. Ended being a blown fuse under the hood.
Good idea, there is an ECM/BCM fuse in the underhood block i believe.
 

·
Worthless reject member
Joined
·
49,289 Posts
At least that was my idea. The whole segment swap thing is still a tad confusing to me.
Not sure if they could be termed as different processes, or subroutines... but just different peices of software in the ECM responsible for handling a specific aspect of powertrain control.

As far as the E40 issue and lack of availability of 05 specific service # ECMs, I guess it really depends in exactly what the incompatibility issue is between the 05 and 06 ECM's and the software.

When i get red back, i'll eventually drop my spare 5.7 in it and try both ECM's. We'll see what happens.

If it runs on both, ok great, but now we would have to figure out how to use an 06 E40 the right way without disabling VATS. Just having flashed at the dealer would brick it because they would flash a stock 05 calibration.

The question i would have is, can you link an 05 BCM to an 06 ECM with 06 specific software. If not, would a segment swap help? I'd have to check to see if the OS was different between the two. I might do that with my bench harness when i get a chance.

Kind of wish I had a tech II and the BCM code to try.
 
21 - 28 of 28 Posts
Top