LS1GTO Forums banner

1 - 8 of 8 Posts

·
05' CGM GTO
Joined
·
3,548 Posts
Discussion Starter #1
My clutch seems to burn alot now when im tearing it up into second gear. I Know most of you are gonna say its my driving but i havent changed nothing and it didnt smell back at 12000 miles. It only smells during spirited driving. I havent really noticed any performance loss other than it seems hard to get the tires to spin hitting second. My chirps are very weak i used to be able to lose traction for a couple seconds. Is this a sign of new clutch needed? How much time is left on my clutch? And what is a "slippin" clutch feel like?
 

·
Registered
Joined
·
258 Posts
Yep, sounds like your clutch is going. Best way to see if clutch is slipping bad is to put your car in 5th at about 30 mph, then floor it. If your engine revs, but your car does not acccelerate, your clutch is toast. If you are still barking alittle between the 1-2 shift you still have lots of wear left. I had an RX-7 that I went through 3 clutches in 15 months (I was 18), so I have some knowledge about when clutches go bad.
 

·
Still a communist state
Joined
·
12,479 Posts
time for an ls7 clutch :gears:
 

·
05' CGM GTO
Joined
·
3,548 Posts
Discussion Starter #4
what do you mean by barking?
 

·
Moving Forward
Joined
·
2,163 Posts
I get a smelly clutch every so often, but the car still bites on the 1-2. Sometimes you just let out the clutch too slow and you let it rub more then catch and you will get that smell.
 

·
05' CGM GTO
Joined
·
3,548 Posts
Discussion Starter #7
Yeh i suppose it could be driver error. Im just not sure what im doing. I havent changed my shifting since i got the car, and if anything its getting better. I dont see how i could ride the clutch to long as its a first to 2nd shift at 6200 rpm. aka its the shortest shift i ever throw. It could be my timeing? but my throttle/clutch feels perfectly fine. the rpms dont rev before im actualy accelerating again, it doesnt feel jerky or strange whatsoever. It basically (not bragging) feels like a perfect shift and i couldnt see it being any smoother, maybe slightly quicker, but not smoother.
The only other time ive smelt a burning clutch (3-4 weeks prior to now) is when i held myself on a hill at a drive threw that was taking to long. needless to say i dont hold myself on hills anymore.

I dont seem to have any issues when flooring it at like 35 in 5th it just goes when i touch the throttle. Only thing left is driver error but i dont see were.
 

·
Premium Member
Joined
·
11,167 Posts
sporaclic said:
Yeh i suppose it could be driver error. Im just not sure what im doing. I havent changed my shifting since i got the car, and if anything its getting better. I dont see how i could ride the clutch to long as its a first to 2nd shift at 6200 rpm. aka its the shortest shift i ever throw. It could be my timeing? but my throttle/clutch feels perfectly fine. the rpms dont rev before im actualy accelerating again, it doesnt feel jerky or strange whatsoever. It basically (not bragging) feels like a perfect shift and i couldnt see it being any smoother, maybe slightly quicker, but not smoother.
The only other time ive smelt a burning clutch (3-4 weeks prior to now) is when i held myself on a hill at a drive threw that was taking to long. needless to say i dont hold myself on hills anymore.

I dont seem to have any issues when flooring it at like 35 in 5th it just goes when i touch the throttle. Only thing left is driver error but i dont see were.
After you hit 2nd, are you making sure your left foot is not dwelling on the clutch a bit. I had that problem on a couple hard accels because after hitting that first shift, third comes so damn quick I found I wasn't letting off fully...anticipating the next shift. After just paying attention a couple times, I've never had the problem again.

Gerry
 
1 - 8 of 8 Posts
Top