LS1GTO Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1
The factory radio in my 2005 GTO stopped paying CDs. It loads all 6 fine, and can eject them with no issues, but they won't play. It seems to think for a while then I get a CD error message and nothing. Not sure if its electrical and the laser isn't working or can't start reading the discs, or if the CD isn't spinning correctly, like the motor isn't working or maybe the rubber band drive finally gave out after 15 years. Mileage is pretty low (32,000) so it is in good shape. I really didn't want to swap radios and possibly loose the steering wheel controls, as I'm trying to keep this all stock. Just wondering if anyone has any thoughts or knows someone who still fixes these radios.I wouldn't be opposed to just getting another head unit on ebay as they are pretty cheap, but I am worried if its an age thing another might be susceptible to the same issues, as well as the problem getting the code for the new radio, as almost all the sellers have no codes, and all they promise is the original car's VIN so they hope my incompetent local parts dept. can "look it up". Not sure if that's a good idea.
 

·
Registered
Joined
·
69 Posts
I have been through 2 units since 2011. I bought mine from a member here .... even had one converted by him with an aux jack to play off my phone.
They both played fine .... don't remember if I had to use a code or not. I think he sets it up where you dont have to use one. I can't remember for sure.
Both of mine fail to "Load" .....
I haven't checked on any repairs as of yet .... but this forum should be the place to start.
Good luck.... and keep us updated.

Edit .... here's the member's website I used .
Pontiac GTO - Bohnman Customs
 

·
Administrator
Joined
·
8,362 Posts
People still use CD's? If you want to retain the stock look, send the unit to Bohnman and have him do the AUX input mod.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #6
Thanks for your responses everyone. I had heard about Bohnman's before but wasn't sure if he fixed as well as added the aux inputs. I wanted that added anyway, so I guess that will be the way to go if it can be fixed. I would love to be able to keep the original radio as this car is all near mint and even came with the owner's card that has the radio code, etc. Thanks again everyone.
 

·
Registered
Joined
·
71 Posts
Have you tried one of those cleaning discs to see if maybe the lens is just a bit dusty?
 

·
Registered
Joined
·
749 Posts
Mine would give me a 'mech error' or something like that. I ended it up taking it out of the car, and this disassembling it to retrieve all of my CDs in it. Even tried a YT video on how to repair it, but I didn't have any luck. I ended replacing it with an Alpine CDW 265 (?) unit that was very similiar to stock (non-touch screen) and that both improved my sound quality and let me add a bluetooth 'car phone' of sorts.
 
1 - 9 of 9 Posts
Top