LS1GTO.com Forums banner

1 - 14 of 14 Posts

·
Shooting Wide Open
Joined
·
1,525 Posts
Discussion Starter #1
EDIT: i meant reverse light, not renderse light in the title, but i cant change it LOL.

Hey all, I have the following glitch in my car that just started happening and I wanted to drop you a line and see if anyone have the same issue or had it in the past and it got resolved by your dealer.

I noticed the other day that when i went to use my turn signals, they were not working. I noticed the 15a fuse was blown. I replaced the fuse and everything worked again. I started up the car in nuteral and turned the turn signal on. I put the car into reverse and the fuse promptly blew again...I replaced the fuse yet again, and the same issue again. The fuse controls the reverse lights as well, so they did not work either.

Bulbs are all fine.

After searching and reading about others that have had similar issues, there is still no definitive cause i can find to tell my dealer.

I understand its only a M6 issue, and it's only when you put the car into reverse that the fuse blows.

I have no aftermarket electrical stuff in the car at all, and there has been no work done on the car for quite a while before this happened.

My guess is it's a bad reverse sensor that might be shorting stuff out. Any ideas?
If this has happened to you and you know the bad part number that the dealer replaced, that would be great to know.

Thanks in advance guys.

Macro
 

·
Shooting Wide Open
Joined
·
1,525 Posts
Discussion Starter #2
I just realized as well that the fuse does not blow if you put the car in reverse it's only when you begin to let the clutch out that it blows.

Any suggestion on what might that be from?

Macro
 

·
Big Blue
Joined
·
2,168 Posts
Had the exact same problem. That fuse controls the turn signals, reverse lights, and headlight switch illumination. My dealer replaced some sort of reverse switch that they said was located on the transmission. Hope this helps.

Jason
 

·
Vegemite powered
Joined
·
85 Posts
Had the exact same problem. That fuse controls the turn signals, reverse lights, and headlight switch illumination. My dealer replaced some sort of reverse switch that they said was located on the transmission. Hope this helps.

Jason


Any more details on this, it just started happening to me ? Was it a cheap fix at the dealer or is it a DIY repair ?

Thanks,


FD
 

·
Suffering Fools
Joined
·
15,248 Posts
If it's the reverse light switch, it should be a cheap fix.

I think the switch is $20 or so, and you can reach it easily from under the car.
 

·
Shooting Wide Open
Joined
·
1,525 Posts
Discussion Starter #7
If it's the reverse light switch, it should be a cheap fix.

I think the switch is $20 or so, and you can reach it easily from under the car.
That is correct. Brought mine into the dealer and it was all squared away.

It was weird as hell for a while though - couldn't figure it out.

Macro
 

·
Shooting Wide Open
Joined
·
1,525 Posts
Discussion Starter #10
yea, this happened to me w/ 100 miles on the car. Went through a case of fuses till I finally said F' this and took it to the dealer.......
LOL thats exactly what i did!!

Thank god its a simple fix and was under warranty.

Macro
 

·
2004 Phantom Blk/Blk
Joined
·
54 Posts
turn signal reverse light fuse

I have the same thing going on, any part numbers for the switch?
 

·
Shooting Wide Open
Joined
·
1,525 Posts
Discussion Starter #12
I have the same thing going on, any part numbers for the switch?
hey busta, unfortunately i do not have a part number for it. I would just take it to your dealer and it will be fixed. Its not a major deal.

Macro
 
1 - 14 of 14 Posts
Top