LS1GTO Forums banner

161 - 180 of 212 Posts

·
Registered
Joined
·
242 Posts
Well, I got up to putting the head unit on - decided to stop and get a 2bar map. You are definitely correct, the installation leaves a lot of interpretation.
 

·
Registered
Joined
·
242 Posts
Decently productive day, got the head unit mounted minus one bolt, coolant pump in, still need to pin the crank and think of some sort of intake solution. Big shout out to SkiPopeye for all the help!
 

·
Administrator
Joined
·
8,723 Posts
Discussion Starter · #167 ·
Pucker moment is an understatement. I absolutely thought I was going to snap the bolt.

Glad you’re making progress. Keep the texts coming my way if you have any other questions.
 

·
Registered
Joined
·
242 Posts
Not liking the coolant hose, the one off the bottom of the rad to the pump keeps wanting to kink on me. Everything else is buttoned up now though, still need to do the pump install but I'm guessing comparatively that should be easy.
 

·
Administrator
Joined
·
8,723 Posts
Discussion Starter · #169 ·
Yeah, I ended up opening the hole in the plastic shroud a bit to allow the hose to have more room to bend. That fixed the issue for me.

As far as the pump install, make sure you don’t use the drill bit size they call for in the instructions. It’s the same damn size as the self tapping bolts. Found that out when I went to install them and had to drill 2 new holes 🤦🏽‍♂️
 

·
Administrator
Joined
·
8,723 Posts
Discussion Starter · #170 ·
What are you doing about a tune? Do you have HP Tuners and a baseline tune to upload to get you running, or are you going to trailer it to a shop?
 

·
Registered
Joined
·
242 Posts
Im unsure for tune - been talking to Davenport (our local LS guys) about a baseline tune, but I'll probably end up trailering it as they seem reluctant to give me a baseline, maybe for liability issues. Luckily for me theyre only about 10 minutes away and are arguably the best for LS cars
 

·
Administrator
Joined
·
8,723 Posts
Discussion Starter · #172 ·
Well that’s awesome to have a shop that close to you.
 

·
Registered
Joined
·
242 Posts
Few questions:

Yellow line off the PCV on the drivers side valve cover into one of the inlet barbs on tvs, red from booster to an inlet barb. Green is the evap running around the tvs into the inlet barb on passenger side. Yellow is where you would tie in a catch can right? However it was blocked off and I had catch can installed ont he vent on the passenger side, which I was always told was the side that had more pressure. Anyways, I'm not sure this is right. I'll prbably delete the evap system and have it tuned out and maybe just plug the evap.
503732
 

·
Registered
Joined
·
242 Posts
Also thinking of ignoring the TB steam lines and going straight from radiator to the crossover with a 1/4" to 11/32" step down in the line.
503733
 

·
Registered
Joined
·
242 Posts
Throttle cable seems a little tight, I adjusted to max and the throttlebody doesnt quite close alll the way. Not sure if i need to try and bend the holder or maybe add a washer or two to bring it forward.
 

·
Administrator
Joined
·
8,723 Posts
Discussion Starter · #177 ·
Post / text me a pic of how you have everything laid out and secured.
 

·
Registered
Joined
·
242 Posts
Sure, will do. Still need to make an intake up. Went to a local store and they wanted $240 for a pair of 4" elbows and a 10" aluminum pipe... I cant spend that in principle, so I'm going to use some 4" dust collector parts until the order comes in to at least get it started.
 

·
Registered
Joined
·
242 Posts
I fabbed up an imitation Hardcore intake, but I am now worried about how exposed the filter actually is to the wheel well. Not a huge deal I guess since our weather is usually dry and dusty.
 

·
Administrator
Joined
·
8,723 Posts
Discussion Starter · #180 ·
👍🏽
 
161 - 180 of 212 Posts
Top